Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

It seems that in the Window version of Skype, there is an option to clear chat history. It is supposed to be Tools > Options > IM & SMS > Clear history button but effectively nothing similar is here:

No clear history button

This option is not present on the version that come with my Ubuntu 13.04. In the privacy settings there is this option:

enter image description here

and somewhere in the Skype forum it is said that changing that to Disable History and then restarting Skype will get rid of the chat history. Tried that, don't work.

Searching a bit I found that you have to eliminate some file in the Skype directory; I did that from the directory I have:

cd $HOME/.Skype/my_skype_name/ 
rm chat*.dbb user*.dbb 

...still no go. Before I get rid of all the .Skype directory and re-configure all Skype, is there anyone that know how to do it? The content of the directory is:

alert2048.dbb       chatsync             httpfe           msn.db-journal
alert4096.dbb       config.lck           keyval.db        msn.lock
bistats.db          config.xml           keyval.lock      profile16384.dbb
bistats.db-journal  contactgroup256.dbb  main.db          sms512.dbb
bistats.lock        dc.db                main.db-journal  transfer256.dbb
call256.dbb         eas.db               main.lock        voicemail
callmember256.dbb   eas.db-journal       msn.db           voicemail256.dbb

Removing all other *.dbb doesn't work, either.

Lesson: never put sensitive data on a Skype chat.

share|improve this question
Try this. Click on Tools --> Options --> IM & SMS and the Clear history button. – Mitch Nov 22 '13 at 6:17
@Mitch, that button is available in the widows and Mac version of Skepe, but not on Linux, as I say in the first paragraph of the question... What version are you checking? – Rmano Nov 22 '13 at 13:58

5 Answers 5

up vote 2 down vote accepted

I'm running Linux Mint 17, and was able to clear the chat history. But you won't like the answer.

First I tried expunging all of the data in the ./Skype directory. Didn't help, as everyone above has pointed out.

I have Windows XP installed in an Oracle VirtualBox VM. I installed Skype in the VM Windows, then followed the instructions above.

Anyway, after deleting the old chats using the Windows installation, I went back to Linux Mint, started Skype, and guess what, folks? --no chat history.

share|improve this answer
That really means that Skype is keeping that data online, and that does not provide Linux users with a way to delete it. Nice... Thanks anyway, +1. – Rmano Nov 19 '14 at 17:07

How about nuke it? WARNING This will effectively nuke your Skype profile:

First, do a backup:

cp -r ~/.Skype ~/skype.bk

Now remove the .Skype directory:

rm -r ~/.Skype


Note that this will only remove the local copy of the history which will be restored by Skype on sign in.

share|improve this answer
Yep. Last resort weapon. ;-) – Rmano Dec 13 '13 at 20:31
@Rmano wait, didn't we reach that stage already? – Braiam Dec 13 '13 at 20:32
I've disabled the chat history in the options, quit Skype, removed the ~/.Skype directory. When I sign back in I can see all my contacts slowly getting reloaded from Internet and after a while all my conversations are reloaded as well. Using Skype 4.2. – Krige Mar 31 '14 at 12:29
@Krige if it's like that, then the history isn't locally stored. – Braiam Mar 31 '14 at 12:38
@Braiam, that's what I guessed. So how do we get to clear the chat history in such cases? – Krige Apr 2 '14 at 13:57

the terminal way of doing it, say the user’s skype username is ‘rome’ and the computer’s name is ‘russia’ :

rome@russia:~$ cd /home/rome/.Skype/rome/
rome@russia:~$ rm -rf `find . -name "*.dbb"
share|improve this answer
As you could read in the last paragraph in the question, I tried it. Doesn't work. It forgets very old chat content, not all of them. – Rmano Nov 22 '13 at 15:55

I was instructed by Skype customer service to do following:

  1. Go to Options -> Privacy and set "Keep chat history for.." to Disable History, than sign out & sign in.

  2. Go to $HOME/.Skype/my_skype_name/ and delete only main.db. Sign out & Sign in.

It worked.

share|improve this answer

Found this, Helpful, I guess:

Quote: "Found this on the net thanks to the original poster

The current Linux version for skype 2.2 beta is lacking a delete history button and there does not seem to be a bug ticket so, If you want to clear your chat history.

With Skype not running open your home folder select show hidden files find the one .skype rename it to .skypeold (or what ever).

Once you have logged back on skype you can delete the renamed folder

Bear "

share|improve this answer
yinon: this is EXACTLY Braiam answer. – Rmano Feb 18 '14 at 20:12

protected by Community Feb 6 at 13:00

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.