Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just updated to the latest version (11.04) yesterday, and ever since then, the system has been really choppy.

I used to have 10.10 installed, and that was running smooth.

Anyone also experiencing this? Any fixes?

I'm only running Chrome and Netbeans...

share|improve this question
    
I have already posted a bug regarding the same and it has been marked as duplicate of bug no:**763005** And the original bug has been approved by Canonical, so expect a solution from Ubuntu. You can follow the development of this at: Launch pad bug link: 763005 –  Abhijeet May 4 '11 at 13:53

3 Answers 3

up vote 23 down vote accepted
  1. Install CompizConfig SettingsManager

    sudo apt-get install compizconfig-settings-manager

  2. Click on the Composite tab, and un-check Detect refresh rate.

    enter image description here

    enter image description here

  3. Click on the OpenGL tab, and un-check Sync to Vblank.

    enter image description hereenter image description here

share|improve this answer
    
Done - is this something that should take effect immediately, or is a restart required? –  xil3 Apr 29 '11 at 16:06
    
Oh wow... never mind - it seems to have fixed the issue, for the most part. It's not perfect still, but a lot better. –  xil3 Apr 29 '11 at 16:07
    
I have an ATI card too, and Unity was SOOOO choppy at first. but disabling that helped a lot. There are a few more options in Compiz related to tweaking the refresh rate that you may want to look into. Glad it all worked out for you. –  Alan Apr 29 '11 at 17:22
    
xil3, I updated my answer with another step that may also help you. –  Alan Apr 29 '11 at 20:39
    
Thanks a lot Alan! –  xil3 May 2 '11 at 13:12

I had same problem, but, however, in my case adjusting compiz settings didn't help a lot.

I also had ATI drivers installed. Then I noticed ATI had JUST released new ones, which are said to have much better supprot for the latest X and Unity. However, ATI released them too late, and they failed to get into Ubuntu repositories.

What I reccoment you is to uninstall the ATI driver (fglrx) Ubuntu installed for you, and get the newest one from the ATI's site: http://support.amd.com/us/gpudownload/Pages/index.aspx

In my case this provided incredible improvement of overall performance. I hope it will help you too!

share|improve this answer
1  
Overemphasise text much? –  Naftuli Tzvi Kay Feb 2 '12 at 23:43

This link aways help me with my Radeon

http://wiki.cchtml.com/index.php/Ubuntu_Natty_Installation_Guide#Removing_Catalyst.2Ffglrx

share|improve this answer
1  
Welcome to Ask Ubuntu. While this link may answer the question, it would be preferrable to include the essential parts of the answer here, and provide the link for reference. –  Peachy Aug 29 '12 at 11:29

protected by Community Mar 19 '12 at 9:02

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.