Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

New user here, having an issue automounting my extra partitions.

I'm dual-booting Xubuntu and Windows7, and I have a bunch of partitions:

  • A 60gb ext4 partition for "/"..
  • A 60gb ntfs partition for windows7 install..
  • A 200gb ext4 patition for extra linux space..
  • A 200gb ntfs patition for extra windows space..
  • A 350gb ntfs partition for shared data that's meant to be shared..

As of now, both Xubuntu and Windows7 have been installed and are working as expected (for the most part). However, I've been having difficulty automounting my 200gb ext4 and 350gb ntfs partitions through editing fstab! Here's what I'm getting back from blkid;

/dev/sda1: LABEL="System Reserved" UUID="9A064E1E064DFC2F" TYPE="ntfs" 
/dev/sda2: UUID="48E255E5E255D7B0" TYPE="ntfs" 
/dev/sda3: UUID="a9ab4b02-1784-4ece-a610-d5d50c25a76f" TYPE="ext4" 
/dev/sda5: UUID="8588e674-b37a-4dd4-9126-c329d80c60dc" TYPE="swap" 
/dev/sdb5: LABEL="linux_extra_01" UUID="b05b74c0-5e1e-4e60-a712-2f8f43dd6682" TYPE="ext2" 
/dev/sdb6: LABEL="win_extra_01" UUID="146553585FD8F2B5" TYPE="ntfs" 
/dev/sdb7: LABEL="shared_01" UUID="0269D46C148C27CE" TYPE="ntfs" 

My Xubuntu "/" is sda3, my extra space is sdb5, and my shared data is sdb7..

I knew that I needed some mount points, so I made two new directories inside /mnt..

/mnt/expansion_01 for my extra linux-specific data. /mnt/shared_01 for my shared non-OS-specific data (media, music, videos, etc..).

While looking at a few guides, I tried editing my fstab..

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>

# / was on /dev/sda3 during installation
UUID=a9ab4b02-1784-4ece-a610-d5d50c25a76f /               ext4    errors=remount-ro 0       1

# swap was on /dev/sda5 during installation
UUID=8588e674-b37a-4dd4-9126-c329d80c60dc none            swap    sw              0       0

# linux extra partition 01 [/dev/sdb5]..
UUID=b05b74c0-5e1e-4e60-a712-2f8f43dd6682 /mnt/expansion_01 ext4 defaults 0 2

# NTFS shared partition 01 with windows [/dev/sdb7]..
UUID=0269D46C148C27CE /mnt/shared_01 auto,user,exec,nls=utf8,umask=003,gid=46,uid=1000 0 2

However, when Xubuntu starts up, I get an error message that the partitions have failed to mount, prompting me to press S or M to either skip or manually fix them. As this is my first time ever messing around with partitions and mounting, and I'm still very much a Linux newbie, it's very possible that I've overlooked something or made a simple mistake somewhere!

Did I do something wrong? What's wrong here?

share|improve this question

1 Answer 1

Whoops! Here's the stupid, simple answer to my own question!

# NTFS shared partition 01 with windows [/dev/sdb7]..
UUID=0269D46C148C27CE /mnt/shared_01 auto,user,exec,nls=utf8,umask=003,gid=46,uid=1000 0 2

That line is actually missing an important piece of information. I somehow forgot to specify "ntfs-3g" as the type! It should be:

# NTFS shared partition 01 with windows [/dev/sdb7]..
UUID=0269D46C148C27CE /mnt/shared_01 ntfs-3g auto,user,exec,nls=utf8,umask=003,gid=46,uid=1000 0 2

That fixed my issue, my partitions are now mounted properly, and everything is working as it should!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.