Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

How can we remove the launcher that come with Unity on this new Ubuntu version ?

share|improve this question
add comment

18 Answers 18

up vote 9 down vote accepted

In simple words: you can't. By design, the launcher is intended to stay there always. If you want to give it up, the only way to do so is to give up the entire unity interface by switching to some other DE or by switching to the classic GNOME session.

Moving the launcher to some other edge of the screen is also not implemented and wouldn't be, as per Mark's comment on a bug.

share|improve this answer
add comment

In 12.04, you can go to System Settings > Appearance > Behavior and turn on autohide, then turn the sensitivity all the way down. Now the launcher will only show when you press Super.

share|improve this answer
    
Or if you drag icons to the left side of the screen (an issue if you install a dock with drag-n-drop features). –  Rasmus Apr 27 '12 at 7:22
    
In 11.10 it's an issue if you drag anything at all (images from a webpage, for example). –  weberc2 May 2 '12 at 13:31
    
13.04: you can choose the top left corner only (not the whole left side) –  Marius Hofert May 18 '13 at 8:29
add comment
  1. Install ccsm (Compiz Config Settings Manager)

  2. Launch ccsm and click on the "Unity Plugin"

  3. Under "Behavior", change "Hide Launcher" to "autohide"

  4. Change "Reveal Mode" to None.

  5. Disable "Key to show launcher" and "Key to put focus on launcher"

*Disabling "Key to show launcher" may prevent you from accessing the dash. If you omit this part of step 5, you can access the dash, but the launcher will appear non-invasively while the dash is displayed. I don't know of any way to stop this.

Update: 12.04 does things differently, thus this may not work after 11.10.

share|improve this answer
1  
Step 4 is not available in 12.04. See the answer by WarriorIng64 for a workaround. –  Rasmus Apr 27 '12 at 7:25
    
12.04 was released one day before you posted. My answer from February applied to 11.10. ;) I'll update it nonetheless. –  weberc2 May 2 '12 at 13:28
    
With multiple monitors, you may need to change the "Edge stop veliocity" (experimental) to 1 in order to prevent the mouse pointer from getting "stuck" moving between monitors. –  tylerl Sep 26 '12 at 6:25
    
In 12.10 Compiz does not have "none" option for reveal mode. –  pthurmond Apr 19 '13 at 15:58
    
@pthurmond as my answer mentions, this may not work after 11.10 –  weberc2 Apr 20 '13 at 18:04
show 1 more comment

You could do the following:

  1. Install and launch the ComizConfig Settings Manger.
  2. Select the Ubuntu Unity Plugin.
  3. Set the Hide Launcher option to 'Autohide'.
  4. Set the Reveal Mode option from 'Left' to 'None'.

That should do the trick. You may need to execute setsid unity for the changes to apply.

share|improve this answer
2  
+1 for effort. But it's still there until something pushes it out of the way. –  Brandon Bertelsen Oct 14 '11 at 8:23
    
I'm certain. I read those exact steps on another website. Followed them. Same deal, even though auto-hide is selected it's acting much like one would expect from dodge windows. –  Brandon Bertelsen Oct 14 '11 at 8:33
    
Actually, now that I try alternatives. No matter what I set it to, it dodges. –  Brandon Bertelsen Oct 14 '11 at 8:35
    
Perhaps that option just isn't taking. Is there a method to apply the change without ccsm? –  Brandon Bertelsen Oct 14 '11 at 8:36
    
Same for me... Autohide + none, I checked plugin is activated... But still have this stupid pannel. I am not using Unity 2D. –  Waza_Be Oct 14 '11 at 8:46
show 3 more comments

You can go back to the classic GNOME session as described in this answer.

share|improve this answer
add comment

in compiz i went to the unity section and then the experimental tab and set these values to simply 'fool' the bar into never appearing unless the super button is pressed. If I can get the dash to separate from the bar entirely and move it to Cairo dock i will be extremely satisfied. ...........anyway Experimental Tab

  • panel opacity 0.0050
  • Launcher Opacity 0.0000
  • Reveal Edge 0.2000
  • Reveal Pressure 999 (this is the main one so mouse cant grab window)
  • Edge Overcome pressure 1
  • mouse pressure decay 1
  • edge stop 1
  • menu fade in and the rest are all 0
  • launcher captures mouse ....UNCheCkEd

this way their is no hacking just a little easy tweaking and dash is still there and bar is only visible when hitting dash ...... i guess i could go remove all the launchers from it now and then it would hardly be noticeable.....cheers

you can also go in the config editor and change these values with greater range

share|improve this answer
add comment

If you log out, insert your username you can then choose (at the bottom) to log into 'Ubuntu Classic'. That'll get you the old 2 panel style gnome.

share|improve this answer
add comment

at least, you can set it to "autohide", ccsm has an option for that

  1. Install the CompizConfig Settings Manager Install compizconfig-settings-manager (CCSM).
  2. Alt + F2
  3. type about:config and press Enter
  4. change the "hide launcher" setting to "autohide".
share|improve this answer
add comment

If you're using Unity 2d you just rename the file /usr/bin/unity-2d-launcher to something else, it will do the trick. You will lose search functionality too, but the menubar will work.

share|improve this answer
    
Has this been renamed in 12.04? Can't seem to find it. –  Rasmus May 2 '12 at 18:38
add comment

In the file /usr/share/unity-2d/shell/Shell.qml, and can be edited with the command

gksudo gedit /usr/share/unity-2d/shell/Shell.qml

The way to remove the remnant bar that was floating there was to set:

LauncherLoader {
id: launcherLoader
anchors.top: parent.top
anchors.bottom: parent.bottom
width: 0

^Change the width to either 0 or 1, 1 will show 1 pixel, but will not produce graphic artifacts.


Is there a less hack-y way to do this?

The other file can be edited using

gksudo gedit /usr/share/unity-2d/shell/launcher/Launcher.qml

I am aware of the autohide feature in CCSM, however that is not what I am looking for. I wanted to place a separate launcher OVER unity, and the sensitivity of autohide would make it difficult to use both.

share|improve this answer
add comment

Sure when you login, choose your name and when the password box comes up look at the bottom panel and select Ubuntu Classic.

share|improve this answer
1  
I don't mean to be drastic. I like the search facility. I just don't like the launcher on the left side. (because I already use cairo dock). Can't have one without the other ? –  MEM Apr 29 '11 at 14:51
    
You can always patch sources of Unity (if you can :) –  Extender Apr 29 '11 at 16:41
add comment

You can disable the unity plugin in cssm and log out and in again, and it's gone. But before that perhaps add something like awn to your startup applications.

share|improve this answer
    
So a dock is always necessary? –  Jeannie May 12 '11 at 19:24
    
Nope. You can manage well with keyboard shortcuts. –  desgua Oct 2 '11 at 0:56
add comment

Use unity-2d-panel. It's installed by default. To see what that would feel like, press alt+f2 and run metacity --replace && unity-2d-panel.

share|improve this answer
add comment

You could change/disable the reveal mode of the launcher. This will not disable the launcher but then the only way of revealing the launcher will be to press the Super key.

To do this, complete steps 1-3 as mentioned by tobi. Now the settings for the reveal mode is displayed, and all you have to do is change the reveal mode.

share|improve this answer
add comment

I know this is more than a year layer, but I still wanted to give my answer: Install Compiz-Config-Settings-Manager, open it up, DISABLE Unity Plugin completely, install GnoMenu or Cardapio, or any of the other search utilities available as plugins for cairo-dock, and there you go!

Also, instead of trying to fix Gnome, another alternative is KDE. Install kubuntu-desktop from the software center and you won't regret it.

share|improve this answer
add comment

Important:


If would you want gnome panels before disabling launcher;


Navigate to System>Preferences>Startup Applications

Click Add

Name=Gnome panels

Command=gnome-panel

And click close button.

It's ok.


-Unity with gnome panels


Press SUPER key and type

ccsm

than press ENTER.

Disable unity plugin from Compiz Config window (uncheck click box)

Logout & Login to Ubuntu session

-Unity without launcher ...
share|improve this answer
    
Decent's answer is a kind of solution, but if you do so, you get rid not only of the launcher, but also of the search facility. You can keep only the bar on the upper part of the screen. –  user22191 Jul 25 '11 at 12:38
add comment

Use Unity Tweak tool and set the launcher to autohide and then take the reveal sensitivity to the lowest setting, and the unity launcher will only appear when you press super.

By design the Unity Launcher cannot be removed, if you want it gone completely then you can try other desktop environments such as GNOME, Xfce or KDE.

share|improve this answer
add comment

Did you try to hide the Unity Launcher at all? Install Compiz Config Manager (ccsm), run it, and go to Unity Plugin, then open the Advanced Tab (if I remember that correctly -- the last one), and there should be an option to hide the launcher completely. I presume that the Windows-button functionality should still work with dash completely hidden. However, I cannot guarantee this completely removes the launcher, it might, probably, show up when you do something...

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.