Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Kubuntu 13.10.

Working directly in ~/Ubuntu One folder, where I have my Java projects under ~/Ubuntu One/java-projects.

I want to ignore compilation and version control folders: classes, dist, .git, .svn and the like.

Created ~/.config/ubuntuone/syncdaemon.conf which contains:

[__main__]
ignore = \A.*/build\Z 
         \A.*/target\Z
         \A.*/dist\Z 
         \A.*/classes\Z 
         \A.*/lib\Z 
         \A.*/some/other/folders/to/ignore\Z 
         \A.*\..*\Z

Restarted daemon and reboot, but syncdaemon.conf seems to be "ignored" by U1 and nothing is ignored. I have tried different regular expressions but syncdaemon.conf still seems to be ignored.

What's wrong?

Thanks.

share|improve this question
add comment

1 Answer 1

You do not need to specify .*/ as a prefix to directory names. If you want to ignore directories named classes for example, then simply use \Aclasses\Z as the expression. You also cannot ignore explicit paths, as only the base name of the path will be compared to the expression. Thus if you want to ignore ~/Ubuntu One/some/folder you will have to only ignore \Afolder\Z, which will ignore anything in Ubuntu One, with the name of folder.

share|improve this answer
    
The problem seems to be that 'syncdaemon.conf' is not even read. I have tried using \Aclasses\Z regex style but still these folders are synchronized. Hidden folders are also uploaded. I need 'some/folder' because I need to ignore 'folder' inside 'some', not any 'folder'. Using Kubuntu 13.10. –  Antonio Sánchez Nov 20 '13 at 22:04
1  
Why wouldn't it be read? If the file isn't being read, then it is a bug and is off topic (you should file a bug report instead). Anything that isn't ignored will be synchronized, regardless of whether it starts with . or not. And as I stated, you cannot ignore full or relative paths, but only immediate file or directory names. –  dobey Nov 21 '13 at 14:09
    
I'm just a single user who asks before submitting a bug report. Probably I'm doing something wrong (probably something obvious) but I have no idea what it might be and I have no much time to keep testing. If I finally submit a bug report I will link it here. –  Antonio Sánchez Nov 21 '13 at 21:18
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.