Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a VPS set up with Ubuntu 10.04 running exim4 as the MTA. The machine name itself is something easily recognizable to us (in this case, 'Fermat'), but the machine itself is responsible for serving up one of our domains (i.e. www.example.com).

When generating an email from exim, the email headers are reporting the server name (Fermat) instead of the domain name (example.com).

Is there a way to 'force' exim to report the server name as example.com without changing the machine's host name?

share|improve this question
    
This question appears to be abandoned, if you are experiencing a similar issue please ask a new question with details pertaining to your problem. If you feel this question is not abandoned, please flag the question explaining that. :) –  Ringtail Feb 27 '12 at 9:53
add comment

closed as too localized by Luis Alvarado Mar 14 '13 at 16:21

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

2 Answers

Make sure the content of /etc/mailname is example.com. If not, change it and reboot:

sudo nano /etc/mailname
sudo reboot
share|improve this answer
add comment

Reconfigure exim4:

sudo dpkg-reconfigure exim4

One of the questions it'll ask you is for the "System mail name". You want to change that.

share|improve this answer
    
I did this part and even set it to 'example.com'. In the email headers, though, it still shows: Received: from Fermat (mail.example.com [11.22.33.44]) –  jerhinesmith Jul 28 '10 at 20:52
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.