Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've got an MSI GE-40 laptop with an Intel HD 4600 (integrated in Core i7-4702MQ CPU) and GeForce GTX760M GPU running Ubuntu 13.10. It looks like 3D is not supported:

/usr/lib/nux/unity_support_test -p
OpenGL vendor string:   VMware, Inc.
OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 3.3, 256 bits)
OpenGL version string:  2.1 Mesa 9.2.1

Not software rendered:    no
Not blacklisted:          yes
GLX fbconfig:             yes
GLX texture from pixmap:  yes
GL npot or rect textures: yes
GL vertex program:        yes
GL fragment program:      yes
GL vertex buffer object:  yes
GL framebuffer object:    yes
GL version is 1.4+:       yes

Unity 3D supported:       no

I've run glmark2 and it gets a score of 144.

  1. Am I right that 3D is not working (but is being rendered by the CPU instead)?
  2. What can I do to have the Intel GPU support 3D or switch to the NVIDIA GPU?

Thanks in advance. Please let me know if you need more information.

sudo lshw -C video
  *-display UNCLAIMED     
       description: 3D controller
       product: GK106M [GeForce GTX 760M]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: latency=0
       resources: memory:f6000000-f6ffffff memory:e0000000-efffffff memory:f0000000-f1ffffff ioport:e000(size=128) memory:f7000000-f707ffff
  *-display UNCLAIMED
       description: VGA compatible controller
       product: 4th Gen Core Processor Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 06
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller cap_list
       configuration: latency=0
       resources: memory:f7400000-f77fffff memory:d0000000-dfffffff ioport:f000(size=64)
share|improve this question
add comment

1 Answer 1

I've solved the problem. During the installation I had to add the nomodeset kernel parameter. Removing this parameter from /etc/default/grub and running update-grub solved the issue. Now the correct driver is being loaded.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.