Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This question already has an answer here:

I have the latest edition of ubuntu, formated my pc 1 week ago. I Right clicked on the USB flash partition and I sow the format option. It is not grayed out, I do the format, it shows no files when I open the usb file, but when I click on priorities, it shows 94% full.

share|improve this question

marked as duplicate by Warren Hill, Mitch, guntbert, karel, Braiam Nov 22 '13 at 0:36

This question was marked as an exact duplicate of an existing question.

You will need to unmount the disk before formatting it. You can do this by clicking on the eject icon next to drive in Nautilus:

nautilus eject icon

You can then right-click on the drive to format it. If you still face problems, try using a more advanced partitioning tool like GParted that will tell you why things aren't working as you expect.

share|improve this answer
    
thank you for your prompt answer! – user217576 Nov 20 '13 at 12:17
    
I will try your second option and see from there, because first one doesn't work for my haunted pc...! – user217576 Nov 20 '13 at 12:18

Not the answer you're looking for? Browse other questions tagged or ask your own question.