Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Since upgrading my Natty install to Gnome 3, I've been having occasional issues with sound. Most of the time, sound works fine, but here and there it will be really staticy.

One cause I've noticed is when the cpu is heavily tasked, this will cause sound to get staticy. Sound then remains staticy and garbled even after tasks finish and cpu usage drops to normal. Forcing Pulseaudio to restart (with "killall pulseaudio") seems to fix the issue for that instance.

The more annoying cause of staticy audio has been running certain games. It happens 100% of the time when these games are running. Linux-native game Trine is really bad, with the sound issues making the game completely unenjoyable. Warcraft III running in Wine also does it, but to a lesser extent.

These games both ran perfectly before the upgrade to Gnome 3, and I'm confused as to why it would change anything. After searching a bit, the only (remotely) similar thread ( crackling audio with Pulseaudio ) I've found says that it could be "bad latency and incorrectly set frequency settings in Pulse Audio".

If it were something as simple as incorrect frequency settings in Pulseaudio, where would one go to change it?

Any help, input, or other assistance is greatly appreciated. Thanks.

share|improve this question
    
Same here. A fresh install of 11.10. I'd love someone to say something about this - hardware is 100% ok, I have a dual boot setup with Win7 which I use for multimedia. –  Swader Dec 17 '11 at 14:21
    
This question appears to be abandoned and unanswered. This will be closed. If this question is still valid, please add more detail and flag for it to be reopened. –  fossfreedom Feb 18 '12 at 22:23
    
Please reopen this?? I am having the exact same issue on a Xubuntu 11.10 fresh install on my Acer Aspire 5810TZ (Timeline). Everything stock and only been approximately 3 to 4 months since install. Only started happening about less than a week ago. Please reopen?? command "killall pulseaudio" also temporarily fixes it for me as well. –  Daniel Clem Mar 4 '12 at 4:19
add comment

closed as too localized by fossfreedom Feb 18 '12 at 22:23

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

Browse other questions tagged or ask your own question.