Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am running a GeForce GTX 770 on a Z87 Gigabyte mobo and dual-boot Windows 8.1 Pro and Ubuntu 12.04.3 LTS. The setup runs smoothly overall except for when it comes to video and 3D performance in Ubuntu. I had the infamous flickering issue at one point and found a way to fix it. It has to do with the NVidia card going into low-power mode and then videos and 3D effects suffer from tearing and stuttering. The fix is to go to nvidia-settings and change the power-mode from 'Auto' to 'Prefer Maximum Performance'. The problem is this only works until I reboot. After the reboot the setting is cleared and the problems still persist, so I have to manually set it again for the current session. I tried gksu-ing and setting it, but it didn't work. I tried to edit the etc/X11/xorg.conf, but it's empty - there are zero lines in that file... I read all the related articles, but mainly people complain about brightness being reset or dual-monitor configs, which solutions involve some specific app that doesn't help me in any way.

TL;DR: NVidia settings are reset after reboot and tried everything I could find on the Internet to no good.

If someone knows what to do in this situation, please share!

Thank you!

EDIT [1]: I did some further digging and it seems there is no obvious or safe solution. Some people have tried to set the performance level manually, but report it's unsafe and may kill the GPU. There is still hope though. I think this could be done through the NVidia profiles option provided from nvidia-settings. The problem is that one needs to know the key in question and the value this key accepts.

I could have put a screenshot here, but I need rep => 10...

I couldn't find a list of the possible keys nor any key values... No luck I guess.

Can someone provide a link or list some useful ones?

Thanks!

EDIT [2]: Finally! Thanks to everybody for the help! I found the solution with the help of vegard torvund and this thread. And thanks to the Ubuntu Google+ Community for spreading the word!

share|improve this question
    
Upload the screenshot to imgur.com and post the link here. –  Avinash Raj Dec 2 '13 at 2:18

5 Answers 5

up vote 4 down vote accepted
+200
  1. Create a xorg.conf file by:

    sudo nvidia-xconfig
    
  2. Look for the Section "Device" part in the xorg.conf file And add this line inside the section:

    Option "RegistryDwords" "PowerMizerEnable=0x1; PerfLevelSrc=0x3322; 
    

Save and reboot your machine

share|improve this answer
    
Thanks! That works, but only with a few adjustments to Option "RegistryDwords" "PowerMizerEnable=0x1; PerfLevelSrc=0x3322; PowerMizerDefault=0x2; PowerMizerDefaultAC=0x2" found here –  kgizdov Dec 3 '13 at 17:23

I'm user of nvidia too, I'm using Ubuntu 12.04 and I was experimenting with my video card and to tell you the thing I had similar problem that you had or have after restart my nvidia settings couldn't be applied and actually my xorg.conf file was empty too! But all of this happened when I downgraded my nvidia drivers and so after all of this problems what I did is ran a simple command in Terminal:

sudo apt-get --reinstall nvidia-settings && sudo apt-get install nvidia-settings

gksudo nvidia-settings

Only what I won't tell you if I did reboot my system or not after reinstalling, just don't remember but after this procedure I got everything working fine, I could access my nvidia settings and apply any stuff there like maximizer and so on, it also replaced my xorg.conf file with complete lines due to my hardware, it even recreates it when it's deleted or lost. But all of this I did at my own risk, maybe it depends on ones hardware. It's just what I did, my story.

share|improve this answer

Don't use NVIDIA setup it don't save parameters, i don't know why. I think the system rewrite settings file at startup.

Use the UBUNTU system/parameters its works. Its works on 13.10 and I think in previous version. But i don't know if "PowerMizerEnable=0x1; PerfLevelSrc=0x3322 can be modified

share|improve this answer
    
That would have worked if I had an xorg.conf set up beforehand, but apparently nor Ubuntu nor NVidia make the effort to make one unless you manually run sudo nvidia-xconfig. –  kgizdov Dec 3 '13 at 17:34

From the official user guide:

"4. Loading Settings Automatically

The NVIDIA X driver does not preserve values set with nvidia-settings
between runs of the X server (or even between logging in and logging
out of X, with xdm, gdm, or kdm).  This is intentional, because
different users may have different preferences, thus these settings
are stored on a per user basis in a configuration file stored in
the user's home directory.

The configuration file is named "~/.nvidia-settings-rc".  You can
specify a different configuration file name with the "--config"
commandline option.

After you have run nvidia-settings once and have generated a
configuration file, you can then run:

    nvidia-settings --load-config-only

at any time in the future to upload these settings to the X
server again.  For example, you might place the above command in
your ~/.xinitrc file so that your settings are applied automatically
when you log in to X.

Your .xinitrc file, which controls what X applications should
be started when you log into X (or startx), might look something
like this:

    nvidia-settings --load-config-only &
    xterm &
    evilwm

or:

    nvidia-settings --load-config-only &
    gnome-session

If you do not already have an ~/.xinitrc file, then chances are that
xinit is using a system-wide xinitrc file.  This system wide file
is typically here:

    /etc/X11/xinit/xinitrc

To use it, but also have nvidia-settings upload your settings,
you could create an ~/.xinitrc with the contents:

    nvidia-settings --load-config-only &
    . /etc/X11/xinit/xinitrc

System administrators may choose to place the nvidia-settings load
command directly in the system xinitrc script.

Please see the xinit(1) manpage for further details of configuring
your ~/.xinitrc file.

"

share|improve this answer
    
Figured as much, but I was looking to setup profiles in a config file. Anyway, I found a better solution. Thanks –  kgizdov Dec 3 '13 at 17:18

Alt+F2 and on the command type gksu nvidia-settings Save X Configuration /etc/X11/xorg.conf

share|improve this answer
    
Tried this and doesn't work... Isn't Ctrl + Alt + T for a terminal? –  kgizdov Nov 23 '13 at 0:42
    
Why the downvotes? This works. First you need to issue sudo nvidia-xconfig and then open nvidia-settings with sudo as well. Then set what you want, save to xorg. It WILL work. –  Shiki Dec 2 '13 at 7:45
    
Yes, but there is no mention of the command sudo nvidia-xconfig in his answer... –  kgizdov Dec 3 '13 at 17:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.