Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I can't install flashplugin-installer after having upgraded from Maverick to Natty. Something crashes during the installation:

$ sudo aptitude install flashplugin-installer
The following NEW packages will be installed:
flashplugin-installer nspluginwrapper{a} 
0 packages upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
Need to get 185 kB of archives. After unpacking 770 kB will be used.
Do you want to continue? [Y/n/?] 
Get:1 http://dk.archive.ubuntu.com/ubuntu/ natty/multiverse nspluginwrapper amd64 1.2.2-0ubuntu9 [175 kB]
Get:2 http://dk.archive.ubuntu.com/ubuntu/ natty/multiverse flashplugin-installer amd64 10.2.159.1ubuntu1 [9.370 B]
Fetched 185 kB in 1s (180 kB/s)           
Preconfiguring packages ...
Selecting previously deselected package nspluginwrapper.
(Reading database ... 303033 files and directories currently installed.)
Unpacking nspluginwrapper (from .../nspluginwrapper_1.2.2-0ubuntu9_amd64.deb) ...
Selecting previously deselected package flashplugin-installer.
Unpacking flashplugin-installer (from .../flashplugin-installer_10.2.159.1ubuntu1_amd64.deb) ...
Processing triggers for man-db ...
Setting up nspluginwrapper (1.2.2-0ubuntu9) ...
plugin dirs: :/var/lib/flashplugin-installer/
Auto-update plugins from /usr/lib/mozilla/plugins
Looking for plugins in /usr/lib/mozilla/plugins
Segmentation fault
dpkg: error processing nspluginwrapper (--configure):
subprocess installed post-installation script returned error exit status 139
dpkg: dependency problems prevent configuration of flashplugin-installer:
flashplugin-installer depends on nspluginwrapper (>= 0.9.91.4-2ubuntu1); however:
Package nspluginwrapper is not configured yet.
dpkg: error processing flashplugin-installer (--configure):
dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
                                                    Errors were encountered while processing:
nspluginwrapper
flashplugin-installer
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install.  Trying to recover:
Setting up nspluginwrapper (1.2.2-0ubuntu9) ...
plugin dirs: :/var/lib/flashplugin-installer/
Auto-update plugins from /usr/lib/mozilla/plugins
Looking for plugins in /usr/lib/mozilla/plugins
Segmentation fault
dpkg: error processing nspluginwrapper (--configure):
subprocess installed post-installation script returned error exit status 139
dpkg: dependency problems prevent configuration of flashplugin-installer:
flashplugin-installer depends on nspluginwrapper (>= 0.9.91.4-2ubuntu1); however:
Package nspluginwrapper is not configured yet.
dpkg: error processing flashplugin-installer (--configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:
nspluginwrapper
flashplugin-installer
share|improve this question

1 Answer 1

This was caused by the google-talkplugin package. Uninstalled it and the flashplugin-installer worked perfectly. After that I could re-install google-talkplugin.

share|improve this answer
    
thx, after removing google-talkplugin, flashplugin-installer could finish --configuring again –  AmanicA May 2 '11 at 20:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.