Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Possible Duplicate:
Unity doesn't load, no Launcher, no Dash appears

I downloaded Ubuntu 11.04 onto a USB stick in order to run a live version from there. For some reason, Unity doesn't start, but Gnome does. Also, I tried changing the session environment(e.g., Ubuntu/classic), but they all load Gnome.

So, why doesn't Unity work?

share|improve this question

marked as duplicate by Jorge Castro, hexafraction, Eliah Kagan, jokerdino, Anwar Shah Oct 1 '12 at 17:41

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

It could be your computer hardware. Unity is kind of graphics hardware dependent IIRC. There is Unity 2D option w/c is almost the same if you just want to try it out. It (Unity) will work on a VirtualBox upgraded to 4.0.6 with the latest guest additions.

And once you've downloaded Unity 2D, if you decide to go that course, logout and makes ure you select Unity 2D from the options at the login screen. :)

share|improve this answer

Something similar happened to me.

I logged in Ubuntu classic mode and when I went back to Unity it didn't loaded i just got the wallpaper, and no panel or launcher.

I did this to fix it:

Logged in Ubuntu classic mode (without effects), then opened CCSM, deactivated gnome compatibility and activated unity plugin.

In my case was some conflict between these two plugins.

If your hardware does not support 3d acceleration try installing unity 2d or using a proprietary driver for your graphics card.

share|improve this answer

I was having this problem even after installing the latest drivers and fiddling with CCSM. I found an entry for Metacity in "Startup Applications" that was clobbering Unity on login. Disabling that entry fixed the problem for me.

If that doesn't work, you can try adding an entry for /usr/bin/unity.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.