Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just installed Ubuntu 12.04 on my 5-yr-old Dell Netbook in hopes of replacing Win XP. I know diddly about Linux, but I used to be able to get through DOS instructions, so I can type in a terminal.

The system shows a wifi wedge, but won't connect to anything. I've been reading about wireless here, and have downloaded, via XP, the 32-bit driver file from Broadcom. I'm reading their instructions, but I don't understand. I have to compile this file?

Broadcom's instructions say:

On Ubuntu, you will need headers and tools. Try these commands:

apt-get install build-essential linux-headers-generic

I opened a terminal and typed that in. I got

    E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied)
    E: Unable to lock the administration directory /var/lib/dpkg/), are you root?

What's all that mean?

apt-get build-dep linux

I typed that in and got the same two lines.

To check to see if you have this directory do this:

ls /lib/modules/*uname* -r/build

That gave me 7 columns of words (folder names?), some in blue, some cyan, and one white.

BUILD INSTRUCTIONS

1. Setup the directory by untarring the proper tarball:

For 64 bit: hybrid-v35_64-nodebug-pcoem-portsrc.tar.gz

Example:

mkdir hybrid_wl

cd hybrid_wl

I managed to make the directory and to change directory (DOS commands!). I also managed with the desktop file manager to move the tarball to the hybrid_wl folder so it would be easy to get at. But I stopped there as the earlier command responses seem to mean that something's missing.

tar xzf <path>/hybrid-v35-nodebug-pcoem-portsrc.tar.gz or

<path>/hybrid-v35_64-nodebug-pcoem-portsrc.tar.gz

2. Build the driver as a Linux loadable kernel module (LKM):

make clean (optional)

make

When the build completes, it will produce a wl.ko file in the top level directory.

If your driver does not build, check to make sure you have installed the kernel package described in the requirements above.


I thought root was like Win admin. I'm the only user. I must be root, right? What's up with root and permission denied? How do I get past or fix that?

Also, when I was using the folder app to move the tarball, I right-clicked it out of habit, and discovered there are both an Archive Manager and an Archive Mounter with which I could open it. If I use one of those can I skip all the rest of this?

I'm sorry if this is hard to read. Your formatting controls are none I've encountered on a website before. Linux, perhaps? And I've no clue why some text is wrapping and some isn't.

share|improve this question
1  
place sudo before all the commands.(like sudo apt-get install build-essential linux-headers-generic) –  Avinash Raj Nov 19 '13 at 5:13
    
can you give us a link to the website? it would be much better. ... P.S: fixed the formatting issues –  Mina Michael Nov 19 '13 at 11:58
    
Thank you both Avinash and Mina. Here's the location of the tar.gz files: broadcom.com/support/802.11/linux_sta.php and here is the readme that goes with them: broadcom.com/docs/linux_sta/README.txt I tried using sudo on the first two lines and got the following: Reading package lists... Done Building dependency tree Reading state information... Done E: Unable to locate package build E: Unable to locate package –  Sarah Nov 19 '13 at 17:37
add comment

3 Answers 3

Try to install broadcom drivers from Additional Drivers app - it will install the same driver that you want to install manually

share|improve this answer
    
Ah. Bother. It appears that that app only works if you have internet connection, the lack of which is the reason I am going through all this. Thanks though. –  Sarah Nov 19 '13 at 17:48
    
OH! Wait. There's a troubleshooter in this. Maybe that will help. –  Sarah Nov 19 '13 at 17:56
    
Now I'm really confused. The troubleshooting took me to a terminal command to verify that the system can see that I have a wireless card, then took me to this page: ubuntuforums.org/showthread.php?t=880218. That says that there is already a driver for my Broadcom BCM4322 in Ubunto since version 8.04.1. It wants me to "3) Click System->Administration->Hardware Drivers" but I have no idea where to do that. Help? –  Sarah Nov 19 '13 at 18:18
add comment

If I understand the issue well, I think all you're missing is to put sudo before your terminal commands and that's it!

such as:

sudo apt-get install build-essential linux-headers-generic

sudo apt-get build-dep linux

sudo gives the security privileges to the commands. (The privileges of the superuser)

share|improve this answer
    
Yes, thanks. That fixes those commands, but I still don't have the solution to this issue. –  Sarah Nov 19 '13 at 18:53
add comment

Thank you all for your responses. I learned quite a bit and appreciate it.

However, I gave up fumbling with the tarball and terminal commands and just plugged the Ethernet port into my router. Once 12.04 updated (over 200 updates!), it had a driver that worked with my wireless card, and I was up and running on wifi. That taught me something, too. Reminded me that I'm sometimes too stubborn for my own good.

Thanks again!

share|improve this answer
    
and that's why updates are so important in ubuntu! :D congrats :D –  Mina Michael Nov 20 '13 at 13:43
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.