Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

After logging in, the desktop appears, and seems to work fine (I can start applications from desktop icons, for example, and right clicking on the desktop area brings up the expected context menu), but there's no menu bar and no dash. How can I fix/diagnose this problem?

This is a very standard clean Ubuntu 11.04 install with only a few fairly standard applications added, such as Chrome, Dropbox and Skype. The only login style that appears to work is "Ubuntu (Safe Mode)"--the two Ubuntu Class styles give the same results as "Ubuntu". I've tried looking in /var/log for messages but there's nothing obvious.

If I create another user account, and login as that user, everything works as expected.

share|improve this question
Please give us details on graphic card & driver – Takkat Apr 29 '11 at 9:06
It's an integrated Intel Graphics card of some sort, neither very old nor very new. How do I find out exactly what it is? – mjs Apr 29 '11 at 9:08
up vote 1 down vote accepted

The answer turned out to be a ~/.gnome-session which contained

/usr/bin/ssh-agent /usr/bin/gnome-session

which must have been necessary at some point in the past, but emphatically isn't now. Once I deleted this file, everything worked as expected.

share|improve this answer
I cant seem to understand the answer. Would one be more specific, as I encountered the same problem after the upgrade to Naty – user15609 Apr 30 '11 at 8:57
ditto. I can only get it to work in safe mode (classic doesn't work, classic without effects doesn't work, unity 2d doesn't work, but they all worked in the beta!) and even then, I can only get window borders by running metacity in the terminal. – Patrick Apr 30 '11 at 18:09
I've updated the answer with more information, but for me the answer was to simply delete ~/.gnome-session. – mjs May 6 '11 at 13:28

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.