Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Cannot access SAMBA share on Ubuntu 12.04 box from XP box.

SAMBA is up and running on the Ubuntu box. smb.conf has the correct windows workgroup name in it, and I can see the Ubuntu box from the XP machine.

On the Ubuntu box, I have set up a UNIX username CCD1 with a password for the purposes of sharing. I have added a Samba username in Samba Server Configuration of UNIX name: ccd1, Windows Username: Mike (username on the XP box), and put in password (same as used for the UNIX username).

I have given access to the Samba shared folder for this username.

On the XP box I can browse the Network Neighborhood, drill down to the workgroup shares and see the Ubuntu box. I can see the shared folder on the Ubuntu box. It is also sharing printers. I can access the printers, I cannot access the shared folder.

Here is how /etc/samba/smb.conf lists the two shares:

[PRINT$]
  comment = all printers
  browseable = no
  path = var/spool/samba
  printable = yes
; guest ok = no
; read only = yes
  create mask = 6766

[CCD_Staff_Dailies]
  comment = Shared Folder
  path = /media/HDD 1/CCD/CCD_Staff_Dailies
  writeable = yes
; browseable = yes
  valid users = sysadmin, ccd1

If I attempt to view the contents of the shared folder from the XP box it doesn't ask for my credentials, I just get:

\Ccd-files-linux\CCD_Staff_Dailies is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions. Access is denied."

share|improve this question
    
have you firewall enabled like ufw. It could block access. I had same message when ufw was enable and port was closed. –  arhimed Nov 18 '13 at 20:59
    
@Pat: It's a clean install of 12.04 and I have not configured ufw or iptables so the firewall is set up per install defaults. I can access that shared folder from another Ubuntu machine, and as mentioned, I can also access the print$ share from the XP machine. –  That Jack Elliott Nov 18 '13 at 21:20
add comment

1 Answer

you need to add the ubuntu box to my network places. there is a good tutorial at http://www.noobslab.com/2012/03/configure-samba-sharing-between-ubuntu.html It helped me out a lot

share|improve this answer
1  
Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  Aditya Jan 12 at 18:31
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.