Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Linux used to automount my windows. But it was a 32-bit Windows, so after installing 64-bit Windows, it no longer automounts. It keeps showing at the start - The disk drive for /windows is not ready yet or not present. Continue to wait, or press S to skip mounting or M for manual recovery. What should I do?

share|improve this question

1 Answer 1

If you had an entry in fstab for your old Windows and you reinstalled it got a new UUID. You need to update fstab with new UUID.

sudo blkid -c /dev/null -o list
sudo cp /etc/fstab /etc/fstab.backup
gksudo gedit /etc/fstab

Change current old UUID for your Windows to the new one.

suggested settings if you do not have these: defaults,nls=utf8,umask=000,uid=1000,windows_names

Also do not hibernate Windows as then it will not mount.

share|improve this answer
    
thank you ! that message is not coming any more. But before it used to show '430 GB Filesystem' under devices. Now thats not there. is that normal? –  ramiz balayil Nov 18 '13 at 19:26
    
i used that first command and saw in the list that it was mounted. THANKS FOR THE HELP!!!! –  ramiz balayil Nov 18 '13 at 20:02
    
Since it was not mounted before it defaulted to your 430GB entry. Better to label all partitions with gparted when created or Disks afterwards with labels that make a little more sense. If you used Nautilus to review the 430GB that would also mount it. And it should show all partitions anyway. –  oldfred Nov 18 '13 at 22:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.