Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am getting an error when I run 'puppet resource services' that complains about the cryptdisks-udev service. The exact error message is as follows:

status: Unknown parameter: DEVNAME

The error can be replicated by issuing the following command 'service cryptdisk-udev' it also responds with the same error. What can be done to resolve this service issue, I only have the swap partition that is relying on cryptdisks at this time. Also no other pertinent logs show up when the command is executed.

Edit: It seems like there may be an environmental variable issue? I am really not sure. If anyone has experienced such an issue I would love to hear what you did to resolve it, as I would like to see the full catalog of services configured on this machine.

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.