Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After waking the system from suspend my networking is disabled and will not start again, this started happening after upgrading from 13.04 to 13.10

sudo lshw -C network

  *-network               
       description: Ethernet interface
       product: RTL8101E/RTL8102E PCI Express Fast Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: eth0
       version: 02
       serial: 90:fb:a6:a8:52:40
       size: 10Mbit/s
       capacity: 100Mbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half latency=0 link=no multicast=yes port=MII speed=10Mbit/s
       resources: irq:44 ioport:6000(size=256) memory:f0010000-f0010fff memory:f0000000-f000ffff memory:f0020000-f003ffff
  *-network
       description: Wireless interface
       product: BCM4313 802.11bgn Wireless Network Adapter
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: eth1
       version: 01
       serial: 00:26:82:a3:fa:70
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=wl0 driverversion=6.30.223.141 (r415941) ip=192.168.0.103 latency=0 multicast=yes wireless=IEEE 802.11abg
       resources: irq:19 memory:f1100000-f1103fff
share|improve this question
    
What is your wireless driver from the terminal: sudo lshw -C network –  chili555 Nov 18 '13 at 16:44
add comment

2 Answers

This technique sometimes, but not always works. Please open a terminal and do:

gksudo gedit /etc/pm/config.d/config

A new, empty file will open. Add a single line:

SUSPEND_MODULES="wl"

Proofread carefully, save and close gedit. It may take a reboot to test it.

share|improve this answer
add comment

Well, I had installed ubuntu 13.10 on a new machine but messed my network setting up.

  1. I installed gksu
  2. Runned: sudo gksu gedit in gedit open your network interfaces file found in etc-network-interfaces
  3. Edit the file with:

    -# This file describes the network interfaces available on your system

    -# and how to activate them. For more information, see interfaces(5).

    -# The loopback network interface

    -auto lo

    -iface lo inet loopback

    -# This is a list of hotpluggable network interfaces.

    -# They will be activated automatically by the hotplug subsystem.

    -# auto eth1

    -# iface eth1 inet dhcp

    then just save it.

  4. Just to make sure everything is ok a. please check your dhcpd.conf file found in etc-dhcp-dhcpd.conf to make sure

    option domain-name "example.org";

    option domain-name-server ns1.example.org, ns2.example.org;

    default-lease-time 600; max-lease-time 7200;

    do not have # before them.

  5. now retart your system and I hope it works just like mine did

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.