Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Each time I reboot my system, the keyboard layout is falling back to US layout even though I want it to be in French layout. This is my default value and this is also the one that is ticked in the keyboard layout menu from the tray. I just need to click once again on the French icon for the layout to get it to work properly but this is quite annoying.

Did someone have the same problem and found a solution? It is apparently a non-unique case since there is already a bug report for this (see this bug report). I am using Ubuntu 13.10.

share|improve this question
    
Yep, same problem here. It appeared in Ubuntu 13.10 back in September, then it vanished and now it seems the bug is back, for me for about two weeks ... I was just trying to ask about the same thing :). Could you please put here a link to that bug? Thanks. –  zubozrout Nov 18 '13 at 18:24
1  
@zubozrout See my edit –  Ludovic C. Nov 18 '13 at 18:31

5 Answers 5

I have the same problem here, but I'm using this workaround:

Go to "System Settings > Text Entry". Under "Input sources to use", add your keyboard layout if it still doesn't exist, then move it to the top of all layouts you already have. Or, if you prefer, you can simply delete all the layouts you don't need and keep only the one you want (that's what I've done here).

Now, open the "Startup Applications", click on Add and do the following:

Name: KeyLaySet (This is made up. Invent your own.)
Command: bash -c "sleep 5 && gsettings set org.gnome.desktop.input-sources current 0"
Comment: Sets keyboard layout to default

About Name:
You can use whatever you want.

About Command:
After the system starts up, it will wait for 5 seconds and then change the keyboard layout to the default one (that one you moved to the top in the "Input sources to use" box).

Click on "Save" and then "Close". Now, every time you start Ubuntu, your keyboard layout will be properly set.

I hope it's helpful. Cheers. :)

brunces

share|improve this answer
up vote 1 down vote accepted

I found a solution that works on my computer but which might not suit all the users...

I just removed the IBus package from the Software Centre and this works fine. After each reboot I now have my favorite layout!

share|improve this answer
    
I wouldn't recommend removing iBus. It changes a lot of other things too. E.g. a lot of items are missing in 'System Settings' ... (Appearance, Color, Display, ...) Had the same problem, the workaround of brunces helped for me too. Upvoted it. –  Tinellus 2 days ago

Do you use the US layout? If you don't, you could try deleting it.

  1. System Settings
  2. Text Entry
  3. Click on the US layout
  4. Click the minus button
share|improve this answer
    
I don't use it regularly so I guess that could be a way to solve that. However it would be nice to get a real idea of what the problem is too! –  Ludovic C. Nov 18 '13 at 16:51
    
Is the problem still there if you delete the US layout and reinstall it? –  maliktunga Nov 18 '13 at 18:06
    
I'll try that as soon as I can do a reboot. –  Ludovic C. Nov 18 '13 at 18:08
    
Yes the problem is still there after removing the US layout and reinstall it (as the third choice) and a reboot. –  Ludovic C. Nov 19 '13 at 7:16
    
Hmm, it's worse than I thought (this solved it for me) ... –  maliktunga Nov 19 '13 at 22:01

Still guessing, in the Text Entry page, does the French layout appear above the US layout? If not, you could try putting it to the top with the up/down arrows and see if that solves the issue.

share|improve this answer
    
Yes French layout is the first one of the list. –  Ludovic C. Nov 18 '13 at 17:38

Another solution shared by scouser73 on another Ask seems to solve the issue :

  1. Open the terminal
  2. sudo restart lightdm
  3. Enter
  4. Type your password
  5. Enter
share|improve this answer

protected by Community Apr 30 at 19:42

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.