Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a Samsung Series 9 NP900X3C, which has a Intel HD Graphics 4000 chip. When I use the the Fn keys for changing the brightness, it shows me a nice OSD and sets the value in


However, this doesn't do anything to the actual screen. Instead, I have to

echo $number >> /sys/class/backlight/intel_backlight/brightness

How do I fix this keybinding?

The same goes for the keyboard illumination, I've found the place in /sys/call/leds/ to set it, but the Fn key combination does diddley-squat.

share|improve this question
I've checked with the Keyboard Shortcuts dialog, and the keys do bind to XF86MonBrightnessUp and XF86MonBrightnessDown. Guess I'll have to make my own workaround script if nobody has a solution. – user207046 Nov 18 '13 at 13:30

Try changing:




in /etc/default/grub. I highly recommend you check out this answer for more details on testing this and then making it permanent. That answer was a solution for the same graphics card that you have.

share|improve this answer
Already had that flag set. Removing the additional acpi_osi=Linux , running update-grub and rebooting did nothing. I'm noticing in the XFCE "User" settings, the option "can use video devices" is deactivated. If I activate it, a reboot will turn it back off. Guess I'll need documentation on what that dialog actually sets. – user207046 Dec 10 '13 at 0:44
Now, removing the keybinding I had for the X86MonBrightnessUp/Down keys and rebooting once more makes the keys pop up the same OSD as before, changing the wrong brightness which does nothing. – user207046 Dec 10 '13 at 0:50

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.