Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I had installed CODE::BLOCKS in Ubuntu 12.04 and it was working jut fine until ~2 days ago when the program start to freezing out every ~10 sec. I decided to reinstall CODE::BLOCKS. First, I did:

$ sudo apt-get remove codeblocks*
$ sudo apt-get purge codeblocks*

Then I reinstall CODE::BLOCKS from Ubuntu Software Center

The reinstallation was successful, but now I get this error:

    Cannot find resources...
    Code::Blocks was configured to be installed in '/usr/local/share/codeblocks'.
    Please use the command-line switch '--prefix' or set the CODEBLOCKS_DATA_DIR  environment variable to point where Code::Blocks is installed,
    or try re-installing the application... 

So, what I already did is to define the variable CODEBLOCKS_DATA_DIR in .bashrc, such that when I do:

$ echo $CODEBLOCKS_DATA_DIR

I get

/usr/share/codeblocks

which is the director I believe it is the right directory, I also include

export LD_LIBRARY_PATH=/usr/lib/codeblocks:${LD_LIBRARY_PATH}

still, I still get the same error (Cannot find resources...)

So my questions are:

1) how do I find the "correct" codeblocks directory? (assuming that the one I wrote is not the right one)

2) How do I fix the problem?

Thanks (everyone) in advance,

Jorge

share|improve this question
    
:( nobody answer... but I solve my problem by reinstalling C::B from the source... first I uninstall everything related with codeblocks using synaptic. Then I follow the instruction from: here and here which is basically the same, the firs one has more details in each step. –  Jorge Mastache Nov 19 '13 at 17:39
add comment

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.