Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

I'm brand new to Ubuntu and I was trying to get multiple monitors to work. After messing around in the nvidia settings, I tried restarting lightdm and it made a noise and prompted me for my password. When I typed it in, it made a noise again and prompted me for my password again. And again, over and over.

I thought it might have been because I ran "sudo lightdm restart &". I restarted my computer but when it came back up, it was still doing this.

I can get at the command prompt but I can't get at the UI/X-Server (still learning the terminology).

How can I log in and actually get at the UI again without it just restarting immediately?

share|improve this question
    
I can login as a guest, though. It just does this when I log in as myself. –  StrixVaria Nov 18 '13 at 2:21
    
I would just like to say to the downvoter that yes, it is a dupe and should be closed, but I wasn't able to find the original in my search, so this question still would serve some purpose in the future redirecting people to a place where they can get an answer if they search the same way I do. –  StrixVaria Nov 18 '13 at 2:52
add comment

marked as duplicate by Braiam, Warren Hill, Mitch, Takkat, Avinash Raj Dec 24 '13 at 8:31

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1 Answer

I was able to fix this by removing ~/.Xauthority.

Specifically, I ran:

sudo mv ~/.Xauthority ~/.Xauthority.old

Just to keep it around in case it didn't work. It did work, though!

share|improve this answer
    
I wish I knew what was causing this, though, since I just had to do it again. –  StrixVaria Nov 18 '13 at 2:47
1  
In many cases it happens when an X server is started using sudo e.g. as sudo startx (which leaves a root-owned .Xauthority in the invoking user's home directory). –  steeldriver Nov 18 '13 at 3:42
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.