Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using a Asus laptop with Ubuntu 12.04.

My internal wifi adapter stopped working. So I put in a usb adapter. But then I had two adapters both trying to connect to the same network, from Which neither can connect. They keep knocking each other offline.

So after doing some research I was went into etc/network/interfaces and changed it. So that wlan0 was manual start instead of auto start. At that point I tried to reboot, and at the splash screen I got a message that the computer was waiting network connection. After a minute or two, that changes to continue booting without correct network configuration. And that's it, it just sits there, doing nothing.

So I boot up with my live CD, and used gksudo nautilus, and went back into the Operating system filesystem (not the filesystem on the cd), and corrected the changes made in the interfaces file,then reboot. Still the same. continue booting without correct network configuration, error msg. I have went back and verified the corrections I made were accurate against the CD filesystem.

So what is happening ?

How did I mess up that bad by just adding iface wlan0 inet manual ( from those instructions I found here ) ?

I decided that was easier than blacklisting, because well it just seemed easier. Just my luck.

Here are the results of some terminal commands, I got these from booting onto the Live CD. I've also had two adapters plugged in together with no problem, but it kept saying wlan0 connected , wlan1 disconnected etc. Until I either get this fixed, or reinstall for all practical purposes it is bricked.

I do have the FN+F2 combination, I didn't do that to start with because that also turns off the USB adapter . After turning wifi off, and rebooting still the same thing, here's the results leaving off the Wired ethernet other than just to mention it. Also you will notice that the wireless adapters are both the same brand, which is unusual.

lspci -nn  
02:00.0 Network Controller [0280]: Ralink Corp. RT5390 Wireless 802.11n 1T/1R PCIe [1814:5390]


lsusb  
Bus 002 Device 003: ID 148f:5370 Ralink Technology, Corp. RT5370 Wireless Adapter


sudo lshw -c network  
* network 
description: Wireless interface
product RT5390 Wireless 802.11n 1T/1R PCIe
Vendor Ralink Corp
physical id: 0
bus info: pci@0000:02:00.0
logical name: wlan0
version: 00
serial: 08:ed:b9:6a:0f
width: 32 bits
clock: 33MHZ
capabilities: pm mse pciexpress bus_master cap_list ethernet physical wireless
configuration: broadcast=yes driver=rt2800pci driverversion=3.8.0-23-generic 
firmware=0.34 latency=0 link=no multicast=yes wireless=IEEE 802.11bgn
resources: irq:17 memory:de800000-de80ffff

*-network 
description: Wireless interface
Physical id: 1
bus info: usb@2:1.2
logical name: wlan1
serial: 7c:dd:90:12:d2:f2
capabilities: ethernet physical wireless
configeration: broadcast=yes driver=rt2800usb driverversion=3.8.0-23-generic firmware=0.29 link=no multicast=yes wireless=IEEE 802.11bgn

*-network
description: Ethernet interface
pysical id: 0
logical name: eth0

sudo rfkill list all
0: asus-wlan: Wireless LAN
                     Soft blocked: yes
                     Hard blocked: no
1: phy0: Wireless LAN
             Soft blocked: yes
             hard blocked: yes
2: phy1 Wireless LAN
             Soft blocked: yes
             Hard blocked: no 
share|improve this question
    
I expect there's a keyboard combination (<alt-F3> on mine) to disable the internal wifi. That might have been a better choice, though I've had multiple wifi adapters plugged in with no ill effects, so I don't know what caused your original problem –  Marc Nov 18 '13 at 3:25
    
Your laptop is not [bricked](en.wikipedia.org/wiki/Brick_(electronics); it is a software not a firmware or hardware problem. –  Ramchandra Apte Nov 18 '13 at 4:17

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.