Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

T410s with white stripesMy dual monitor settings worked perfectly fine until just recently. Now the resolution on the second monitor is very low and it shows white vertical stripes. I am using Ubuntu 12.04 with GNOME 3.4. I am using a docking station for my Thinkpad T410s, that is how the Laptop is connected. The main monitor (which works well) is connected via DVI. The laptop monitor works well wenn not attached to the dual screen system. If I turn off the main monitor via software, the laptop monitor still shows white stripes.

Here is my xrandr -q:

  Screen 0: minimum 320 x 200, current 3360 x 1080, maximum 8192 x 8192
  LVDS1 connected 1440x900+1920+0 (normal left inverted right x axis y axis) 304mm x 190mm
   1440x900       60.1*+   59.9     49.3  
   1360x768       59.8     60.0  
   1152x864       60.0  
   1024x768       60.0  
   800x600        60.3     56.2  
   640x480        59.9  
VGA1 disconnected (normal left inverted right x axis y axis)
HDMI1 disconnected (normal left inverted right x axis y axis)
DP1 disconnected (normal left inverted right x axis y axis)
HDMI2 disconnected (normal left inverted right x axis y axis)
HDMI3 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 509mm x 286mm
   1920x1080      60.0*+
   1280x1024      75.0     60.0  
   1152x864       75.0  
   1024x768       75.1     60.0  
   800x600        75.0     60.3  
   640x480        75.0     60.0  
   720x400        70.1  
DP2 disconnected (normal left inverted right x axis y axis)
DP3 disconnected (normal left inverted right x axis y axis)
share|improve this question
1  
Have you tried with a different DE, like Xfce? –  landroni Feb 12 at 17:23
1  
xrandr output seems ok. Seems stupid but --- have you tried changing the cable? (average HDMI cables and connectors, are, well, average...) –  Rmano Feb 12 at 17:37
1  
Hm, added more details to describe the setup. –  Sina Feb 12 at 19:08
2  
@Sina Please post a complete hardware description –  kamil Feb 14 at 17:09
    
And maybe a photo of the second screen during this set up? –  belkinsa Feb 14 at 21:20
show 1 more comment

4 Answers 4

up vote 2 down vote accepted
+100

If enable dual head mode (two X screens), the second monitor went white after login with unity or unity-2d. After tracking the gnome-session, it is caused by running "nautilus -n" for this configuration. And if kill the nautilus process, the desktop showed up normally on second screen. It is a Bug. Try using Ubuntu 13.10.

share|improve this answer
    
Could you explain how I can reproduce "killing nautilus" just to see if this is really the cause? I killed Nautilus but nothing happened. –  Sina Feb 17 at 13:54
    
I ran 13.10 from USB stick and indeed the issue was not there any more. So I guess thats the sad solution. –  Sina Feb 19 at 16:11
add comment

It sounds like the LCD panel OR the video card are bad, or it could just be a bad driver. Head to the manufacturer's website, download, install and reboot.

Below are some thing to check:

  • Try connecting to an external monitor, if the line appears on the external monitor, the issue is a bad video card. If the issue does NOT appear on the external monitor, the issue is the LCD panel.
  • It might be a simple fix like a loose connection to your laptop display.
  • Could be the cable on the hinge side that is getting worn.
share|improve this answer
    
External monitor works fine. Since I am using a docking station there is not much I can do in terms of cable or loose connection. –  Sina Feb 19 at 15:04
add comment

I suggest to change refresh rate (mainly decrease it) which seems to be the real problem. For instance check this question to see how to change the refresh rate

Try different refresh rate until you got the optimal vision. And for your screen I think it's enough a 1366x768 resolution with a refresh rate of 60

xrandr -s 1360x768 -r 60
share|improve this answer
    
I have the Intel VGA. No Nvidia hardware installed. I tried: sudo xrandr --output LVDS1 --rate 59.9 But it did not change anything. If I typed xrandr again still the same. What am I missing. –  Sina Feb 18 at 18:03
    
@Sina Try this xrandr -s 1360x768 -r 60 or this xrandr -s 1360x768 -r 59.8 –  kamil Feb 18 at 18:11
    
You mean xrandr --output LVDS1 -s 1360x768 -r 59.8, right? Both command work without error but nothing happens. If I do not include --output it cant find the display. The original screen resolution is 1440x900 by the way. –  Sina Feb 18 at 19:21
    
@Sina yes of course I mean it –  kamil Feb 19 at 7:17
1  
it seems a hardware problem! try ubuntu live cd and disconnect your external display to see if it works –  kamil Feb 19 at 7:18
show 1 more comment

The timings are wrong for the laptop display. That looks an awful lot like what happens when it's trying to use the same resolution on two monitors, but one of the monitors is not capable of that resolution.

Try decreasing (or just changing) the resolution on the laptop monitor.

share|improve this answer
    
Tried that. Thats not the issue. Thanks anyways. –  Sina Feb 17 at 1:33
    
Just to be clear, the resolution and refresh rate when it works are both exactly the same when it doesn't work? –  dannysauer Feb 17 at 3:04
    
It does not work. Whatever I do changing the resolution. –  Sina Feb 17 at 13:53
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.