Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

What does that mean, can I not install haskell? I just upgraded to Natty, is that the reason?

As you can see in the screenshot I get this problem in the Software Centre:

enter image description here

The following packages have unmet dependencies:

haskell-platform: Depends: ghc6 (< 6.12.1+) but 6.12.3-1ubuntu7 is to be installed
                  Depends: libghc6-cgi-dev (>= 3001.1.7.2) but 3001.1.7.2-1build1 is to be installed
                  Depends: libghc6-fgl-dev (< 5.4.2.2+) but 5.4.2.2-2build2 is to be installed
                  Depends: libghc6-glut-dev (< 2.1.2.1+) but 2.1.2.1-1build1 is to be installed
                  Depends: libghc6-haskell-src-dev (< 1.0.1.3+) but 1.0.1.3-2build1 is to be installed
                  Depends: libghc6-html-dev (< 1.0.1.2+) but 1.0.1.2-3build2 is to be installed
                  Depends: libghc6-hunit-dev (< 1.2.2.1+) but 1.2.2.1-2build2 is to be installed
                  Depends: libghc6-mtl-dev (< 1.1.0.2+) but 1.1.0.2-10build2 is to be installed
                  Depends: libghc6-network-dev (< 2.2.1.7+) but 2.2.1.7-1build2 is to be installed
                  Depends: libghc6-opengl-dev (< 2.2.3.0+) but 2.2.3.0-2build2 is to be installed
                  Depends: libghc6-parallel-dev (< 2.2.0.1+) but 2.2.0.1-1build1 is to be installed
                  Depends: libghc6-parsec2-dev (< 2.1.0.1+) but 2.1.0.1-2build2 is to be installed
                  Depends: libghc6-quickcheck2-dev (< 2.1.0.3+) but 2.1.0.3-1build2 is to be installed
                  Depends: libghc6-regex-base-dev (< 0.93.1+) but 0.93.1-8build1 is to be installed
                  Depends: libghc6-regex-compat-dev (< 0.92+) but 0.92-6build2 is to be installed
                  Depends: libghc6-regex-posix-dev (< 0.94.1+) but 0.94.1-2build1 is to be installed
                  Depends: libghc6-stm-dev (< 2.1.1.2+) but 2.1.1.2-5build2 is to be installed
                  Depends: libghc6-xhtml-dev (>= 3000.2.0.1) but 3000.2.0.1-6build2 is to be installed
                  Depends: libghc6-zlib-dev (< 0.5.2.0+) but 0.5.2.0-4build2 is to be installed
                  Depends: libghc6-http-dev (>= 40000009) but 40000009-2build1 is to be installed
                  Depends: libghc6-deepseq-dev (< 1.1.0.0+) but 1.1.0.0-2build1 is to be installed
                  Depends: alex (< 2.3.3+) but 2.3.3-1 is to be installed
                  Depends: happy (< 1.18.4-2+) but 1.18.4-2 is to be installed
                  Depends: haddock but it is a virtual package
share|improve this question
    
This is now fixed and in -proposed. See the following answer for more details: askubuntu.com/questions/44709/… –  HaskellElephant Aug 11 '11 at 20:33

2 Answers 2

up vote 2 down vote accepted

Yes, this is because of a bug introduced in Natty; this is Bug #742052.

Unfortunately there's not much you can easily do to get around this.

share|improve this answer
    
I did try that, the same problem. Look at the picture in my updated post. –  Blub Apr 29 '11 at 7:06
    
@Blub I've updated my answer –  8128 Apr 29 '11 at 7:15
1  
that is kind of a big deal –  Blub Apr 29 '11 at 7:43

There is a workaround for this problem:

Use vi and edit the file /var/cache/apt/pkgcache.bin
Find the string 6.12.1+ and change it to 6.12.4+
Save the change and sudo apt-get install haskell-platform will still fail while calling some post-install-script, but it seems usable.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.