Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have no idea why, but when I tried to login this morning a window popped up while in splash screen "Could not start D-Bus. Can you call qdbus?" which when clicked returned me to kdm.

I have consulted answers to people who had a similar problem, but none of the advice helped in my case. I tried changing the ownership of all the files in my home folder, I deleted ~/.XAuthority. No dice. Now I'm at loss for what to do next.

If it's any help here's .xsession-errors:

Xsession: X session started for frana at Sun Nov 17 17:44:01 CET 2013
localuser:frana being added to access control list
Setting IM through im-switch for locale=en_US.
Start IM through /etc/X11/xinit/xinput.d/all_ALL linked to /etc/X11/xinit 
/etc/X11/Xsession.d/90consolekit: line 14: dbus-send: command not found
/etc/X11/Xsession.d/90consolekit: line 18: dbus-send: command not found
startkde: Starting up...
/usr/bin/x-session-manager: 1: /usr/bin/x-session-manager: dbus-launch: not found
startkde: Could not start D-Bus. Can you call qdbus?

and kdm.log:

X.Org X Server 1.11.3
Release Date: 2011-12-16
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.42-37-generic x86_64 Ubuntu
Current Operating System: Linux CF-Book 3.2.0-52-generic #78-Ubuntu SMP Fri Jul 26
16:21:44 UTC 2013 x86_64
Kernel command line: BOOT_IMAGE=/vmlinuz-3.2.0-52-generic root=UUID=6f489c87e29f- 
4c44-83f6-95b071402600 ro quiet splash vt.handoff=7
Build Date: 11 April 2013  01:05:39PM
xorg-server 2:1.11.4-0ubuntu10.13 (For technical support please see    
Current version of pixman: 0.24.4
    Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sun Nov 17 17:44:05 2013
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
klauncher(2230) kdemain: No DBUS session-bus found. Check if you have started the   
DBUS server. 
kdeinit4: Communication error with launcher. Exiting!
kdmgreet(2222)/kdecore (K*TimeZone*): KSystemTimeZones: ktimezoned initialize()    
D-Bus call failed:  "Not connected to D-Bus server" 

kdmgreet(2222)/kdecore (K*TimeZone*): No time zone information obtained from    
QInotifyFileSystemWatcherEngine::addPaths: inotify_add_watch failed: No such file   
or directory

QFileSystemWatcher: failed to add paths: /tmp/0034872719/.config/ibus/bus

share|improve this question
Is the package dbus installed ? –  user26687 Nov 18 '13 at 13:34
Yes, it is. And considering the system was working fine the day before, it would have to uninstall on its own without my knowledge and consent, which I do not find likely at all. –  user216748 Nov 21 '13 at 16:54

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.