Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using XFCE 4.10 (Xubuntu 13.10), when I drag any window to the top of the screen, it gets tiled to half desktop, like this:

Also when I drag the window to the left or right, it doesn't stick vertically.

How can I have it maximize windows when tiling them on the top or bottom of the screen?

share|improve this question
    
It's a feature, not a bug. That's how the developers wanted it and how they implemented it. There is no way to fix it unless you can persuade, bribe or blackmail them to do it for you. Of course you can disable it, see Salt's answer. –  aquaherd Nov 18 '13 at 20:13
    
@aquaherd I don't want to disable it. Is there a way to change its behaviour? Maybe editing some configuration file? –  BackSlash Nov 18 '13 at 21:23
    
I don't know if there's a way to do so while dragging to edges yet, but a workaround I've used is setting keyboard shortcuts for "Maximize", "Tile window to the left", and "Tile window to the right" under Settings > Window Manager > Keyboard. –  ZAD-Man May 29 at 17:11

2 Answers 2

"How can I solve it?" If I take your meaning sir, you are displeased by two default Window Manager settings. One can be found in Settings Manager -> Window Manager Tweaks -> Accessibility -> Automatically tile windows when moving toward the screen edge. For the other, perhaps you are thinking of Settings Manager -> Window Manager -> Advanced -> Wrap workspaces when dragging a window off the screen.

share|improve this answer
    
Did you read the question? When I drag the window on the top of the desktop, it doesn't fit the desktop, it fits just a half of it. So the tiling works but it just doesn't make the window fit the desktop, which is pretty an useless feature. And this happens with the Settings Manager -> Window Manager Tweaks -> Accessibility -> Automatically tile windows when moving toward the screen edge toggled on. And the setting to wrap workspaces doesn't work. –  BackSlash Nov 17 '13 at 21:51

I think the answer is in the (question in the) following link: xubuntu 12.10 window tiling shortcuts

"To align a window to left/right/top/bottom half of a screen with mouse you should go to 'settings editor' -> 'xfwm4' and uncheck 'wrap_windows' property. Now you can drag window beyond the edge of the screen to tile it."

share|improve this answer
    
Doesn't work. As I said, I'm able to tile windows. But I don't want windows to take half screen when tiling them top or bottom, I want them to maximize when tiling them on top or bottom of the screen. –  BackSlash Jan 20 at 16:33

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.