Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

While Ubuntu is starting, the following messages are shown and stays shown for long time:

* Starting LightDM Display Manager                                      [OK]
* Stopping Send an event to indicate plymouth is up                    [OK]
* Starting startpar bridge for notification of upstart job start/stop   [OK]
* Stopping startpar bridge for notification of upstart job start/stop   [OK]

After reaching the login page and attempting to login, the same messages are shown again, then I'm returned to the login page to choose between my my username and a Guest session. If I choose a Guest session, everything goes ok and I login as a Guest.

I tried restarting the machine, and then new, but similar messages appeared:

* Starting LightDM Display Manager                                      [OK]
* Stopping Send an event to indicate plymouth is up                    [OK]
* Starting startpar bridge for notification of upstart job start/stop   [OK]
* Stopping startpar bridge for notification of upstart job start/stop   [OK]
* Starting Mount network filesystems                                    [OK]
* Stopping Mount network filesystems                                    [OK]
* Stopping Send an event to indicate plymouth is up                    [OK]
* Starting startpar bridge for notification of upstart job start/stop   [OK]

And the same scenario is repeated. I can login only using a Guest session. If I use my user, I'm shown these messages, but this time, it took a very long time and I wasn't shown the login page again, so I had to restart my machine.

The thing I can remember that could be causing a problem, is that I added a path to the PATH environment variable in the ~/.pam_environment file. But I remember it was written ok:

PATH=/my/path:${PATH}

And while Ubuntu was starting, I connected my external screen. Could any of this be a cause to this problem ? What is the problem in the first place ?!

I'm using Dell Inspiron 7520 SE.

share|improve this question
1  
Did you tried askubuntu.com/q/223501/169736 or askubuntu.com/q/314362/169736 –  Braiam Nov 17 '13 at 16:59
    
Thanks a million man. None of these solutions were feasible because the system is still fresh (2 days old), but the Alt+number (i.e. Alt+3) trick enabled me to reach my .pam_environment file and remove the file I added earlier. –  Muhammad Gelbana Nov 17 '13 at 17:14
add comment

1 Answer 1

up vote 1 down vote accepted

I really don't know much about pam and its path variables

But If you think adding the path is the cause then just go to recovery mode and and remove the PATH which you added recently..If that is the cause then after changing it your ubuntu should behave properly...

Hope this helps!

share|improve this answer
    
Frankly I doubt it is. How can I go to recovery mode ? –  Muhammad Gelbana Nov 17 '13 at 17:02
    
During the booting time you can see the entry for recovery mode in GRUB menu..If you are not getting grub menu then keep pressing shift after starting the computer –  Null pointer Nov 17 '13 at 17:04
    
Thanks mate :). I didn't actually use the recovery mode feature, but I was able to reach my .pam_environment file by pressing Alt+3 and logging in from the command line. –  Muhammad Gelbana Nov 17 '13 at 17:16
    
That doesn't matter much! ;) The important thing is that your problem is solved now! –  Null pointer Nov 17 '13 at 17:18
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.