Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've been having issues with extremely frequent screen lockups and scrambled text. One possible fix was in mesa 9.2.3. Unfortunately, the latest version in the official repos was mesa 9.2.1. Hence, I tried installing all the debs from here: a ppa marked "don't use this". Sigh.

Anyway, I got a whole bunch of dependency errors. (Ignore the lines about the new kernel. That had previously installed.)

$ sudo dpkg -i *.deb
(Reading database ... 357629 files and directories currently installed.)
Preparing to replace libegl1-mesa:amd64 9.2.1-1ubuntu3 (using libegl1-mesa_9.2.3~brppa-0ubuntu1_amd64.deb) ...
Unpacking replacement libegl1-mesa:amd64 ...
Selecting previously unselected package libegl1-mesa-dbg:amd64.
Unpacking libegl1-mesa-dbg:amd64 (from libegl1-mesa-dbg_9.2.3~brppa-0ubuntu1_amd64.deb) ...
Selecting previously unselected package libegl1-mesa-dev.
Unpacking libegl1-mesa-dev (from libegl1-mesa-dev_9.2.3~brppa-0ubuntu1_amd64.deb) ...
Preparing to replace libegl1-mesa-drivers:amd64 9.2.1-1ubuntu3 (using libegl1-mesa-drivers_9.2.3~brppa-0ubuntu1_amd64.deb) ...
Unpacking replacement libegl1-mesa-drivers:amd64 ...
Selecting previously unselected package libegl1-mesa-drivers-dbg:amd64.
Unpacking libegl1-mesa-drivers-dbg:amd64 (from libegl1-mesa-drivers-dbg_9.2.3~brppa-0ubuntu1_amd64.deb) ...
Preparing to replace libgbm1:amd64 9.2.1-1ubuntu3 (using libgbm1_9.2.3~brppa-0ubuntu1_amd64.deb) ...
Unpacking replacement libgbm1:amd64 ...
Selecting previously unselected package libgbm1-dbg:amd64.
Unpacking libgbm1-dbg:amd64 (from libgbm1-dbg_9.2.3~brppa-0ubuntu1_amd64.deb) ...
Selecting previously unselected package libgbm-dev.
Unpacking libgbm-dev (from libgbm-dev_9.2.3~brppa-0ubuntu1_amd64.deb) ...
Preparing to replace libgl1-mesa-dev 9.2.1-1ubuntu3 (using libgl1-mesa-dev_9.2.3~brppa-0ubuntu1_amd64.deb) ...
Unpacking replacement libgl1-mesa-dev ...
Preparing to replace libgl1-mesa-dri:amd64 9.2.1-1ubuntu3 (using libgl1-mesa-dri_9.2.3~brppa-0ubuntu1_amd64.deb) ...
De-configuring libgl1-mesa-dri:i386 ...
Unpacking replacement libgl1-mesa-dri:amd64 ...
Preparing to replace libgl1-mesa-dri-dbg:amd64 9.2.1-1ubuntu3 (using libgl1-mesa-dri-dbg_9.2.3~brppa-0ubuntu1_amd64.deb) ...
Unpacking replacement libgl1-mesa-dri-dbg:amd64 ...
Selecting previously unselected package libgl1-mesa-dri-experimental:amd64.
Unpacking libgl1-mesa-dri-experimental:amd64 (from libgl1-mesa-dri-experimental_9.2.3~brppa-0ubuntu1_amd64.deb) ...
Selecting previously unselected package libgl1-mesa-dri-experimental-dbg:amd64.
Unpacking libgl1-mesa-dri-experimental-dbg:amd64 (from libgl1-mesa-dri-experimental-dbg_9.2.3~brppa-0ubuntu1_amd64.deb) ...
Preparing to replace libgl1-mesa-glx:amd64 9.2.1-1ubuntu3 (using libgl1-mesa-glx_9.2.3~brppa-0ubuntu1_amd64.deb) ...
De-configuring libgl1-mesa-glx:i386 ...
Unpacking replacement libgl1-mesa-glx:amd64 ...
Selecting previously unselected package libgl1-mesa-glx-dbg:amd64.
Unpacking libgl1-mesa-glx-dbg:amd64 (from libgl1-mesa-glx-dbg_9.2.3~brppa-0ubuntu1_amd64.deb) ...
Preparing to replace libglapi-mesa:amd64 9.2.1-1ubuntu3 (using libglapi-mesa_9.2.3~brppa-0ubuntu1_amd64.deb) ...
De-configuring libglapi-mesa:i386 ...
Unpacking replacement libglapi-mesa:amd64 ...
Selecting previously unselected package libglapi-mesa-dbg:amd64.
Unpacking libglapi-mesa-dbg:amd64 (from libglapi-mesa-dbg_9.2.3~brppa-0ubuntu1_amd64.deb) ...
Selecting previously unselected package libgles1-mesa:amd64.
Unpacking libgles1-mesa:amd64 (from libgles1-mesa_9.2.3~brppa-0ubuntu1_amd64.deb) ...
Selecting previously unselected package libgles1-mesa-dbg:amd64.
Unpacking libgles1-mesa-dbg:amd64 (from libgles1-mesa-dbg_9.2.3~brppa-0ubuntu1_amd64.deb) ...
Selecting previously unselected package libgles1-mesa-dev.
Unpacking libgles1-mesa-dev (from libgles1-mesa-dev_9.2.3~brppa-0ubuntu1_amd64.deb) ...
Preparing to replace libgles2-mesa:amd64 9.2.1-1ubuntu3 (using libgles2-mesa_9.2.3~brppa-0ubuntu1_amd64.deb) ...
Unpacking replacement libgles2-mesa:amd64 ...
Selecting previously unselected package libgles2-mesa-dbg:amd64.
Unpacking libgles2-mesa-dbg:amd64 (from libgles2-mesa-dbg_9.2.3~brppa-0ubuntu1_amd64.deb) ...
Selecting previously unselected package libgles2-mesa-dev.
Unpacking libgles2-mesa-dev (from libgles2-mesa-dev_9.2.3~brppa-0ubuntu1_amd64.deb) ...
Preparing to replace libopenvg1-mesa:amd64 9.2.1-1ubuntu3 (using libopenvg1-mesa_9.2.3~brppa-0ubuntu1_amd64.deb) ...
Unpacking replacement libopenvg1-mesa:amd64 ...
Selecting previously unselected package libopenvg1-mesa-dbg:amd64.
Unpacking libopenvg1-mesa-dbg:amd64 (from libopenvg1-mesa-dbg_9.2.3~brppa-0ubuntu1_amd64.deb) ...
Selecting previously unselected package libopenvg1-mesa-dev.
Unpacking libopenvg1-mesa-dev (from libopenvg1-mesa-dev_9.2.3~brppa-0ubuntu1_amd64.deb) ...
Preparing to replace libosmesa6:amd64 9.2.1-1ubuntu3 (using libosmesa6_9.2.3~brppa-0ubuntu1_amd64.deb) ...
De-configuring libosmesa6:i386 ...
Unpacking replacement libosmesa6:amd64 ...
Selecting previously unselected package libosmesa6-dev.
Unpacking libosmesa6-dev (from libosmesa6-dev_9.2.3~brppa-0ubuntu1_amd64.deb) ...
Preparing to replace libxatracker1:amd64 9.2.1-1ubuntu3 (using libxatracker1_9.2.3~brppa-0ubuntu1_amd64.deb) ...
Unpacking replacement libxatracker1:amd64 ...
Selecting previously unselected package libxatracker1-dbg:amd64.
Unpacking libxatracker1-dbg:amd64 (from libxatracker1-dbg_9.2.3~brppa-0ubuntu1_amd64.deb) ...
Selecting previously unselected package libxatracker-dev.
Unpacking libxatracker-dev (from libxatracker-dev_9.2.3~brppa-0ubuntu1_amd64.deb) ...
Preparing to replace linux-headers-3.11.8-031108 3.11.8-031108.201311122252 (using linux-headers-3.11.8-031108_3.11.8-031108.201311122252_all.deb) ...
Unpacking replacement linux-headers-3.11.8-031108 ...
Preparing to replace linux-headers-3.11.8-031108-generic 3.11.8-031108.201311122252 (using linux-headers-3.11.8-031108-generic_3.11.8-031108.201311122252_amd64.deb) ...
Unpacking replacement linux-headers-3.11.8-031108-generic ...
Preparing to replace linux-image-3.11.8-031108-generic 3.11.8-031108.201311122252 (using linux-image-3.11.8-031108-generic_3.11.8-031108.201311122252_amd64.deb) ...
Done.
Unpacking replacement linux-image-3.11.8-031108-generic ...
Examining /etc/kernel/postrm.d .
run-parts: executing /etc/kernel/postrm.d/initramfs-tools 3.11.8-031108-generic /boot/vmlinuz-3.11.8-031108-generic
run-parts: executing /etc/kernel/postrm.d/zz-extlinux 3.11.8-031108-generic /boot/vmlinuz-3.11.8-031108-generic
P: Checking for EXTLINUX directory... found.
P: Writing config for /boot/vmlinuz-3.9.4-030904-generic...
P: Writing config for /boot/vmlinuz-3.5.0-27-generic...
P: Writing config for /boot/vmlinuz-3.11.8-031108-generic...
P: Writing config for /boot/vmlinuz-3.11.0-12-generic...
P: Writing config for Windows 7 (loader) on /dev/sdb2...
P: Installing debian theme... done.
run-parts: executing /etc/kernel/postrm.d/zz-update-grub 3.11.8-031108-generic /boot/vmlinuz-3.11.8-031108-generic
Preparing to replace mesa-common-dev 9.2.1-1ubuntu3 (using mesa-common-dev_9.2.3~brppa-0ubuntu1_amd64.deb) ...
Unpacking replacement mesa-common-dev ...
dpkg: dependency problems prevent configuration of libegl1-mesa:amd64:
 libegl1-mesa:amd64 depends on libwayland0 (>= 1.0.2); however:
  Package libwayland0:amd64 is not installed.

dpkg: error processing libegl1-mesa:amd64 (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libegl1-mesa-dbg:amd64:
 libegl1-mesa-dbg:amd64 depends on libegl1-mesa (= 9.2.3~brppa-0ubuntu1); however:
  Package libegl1-mesa:amd64 is not configured yet.

dpkg: error processing libegl1-mesa-dbg:amd64 (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libegl1-mesa-dev:
 libegl1-mesa-dev depends on libegl1-mesa (= 9.2.3~brppa-0ubuntu1); however:
  Package libegl1-mesa:amd64 is not configured yet.

dpkg: error processing libegl1-mesa-dev (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libegl1-mesa-drivers:amd64:
 libegl1-mesa-drivers:amd64 depends on libegl1-mesa (= 9.2.3~brppa-0ubuntu1); however:
  Package libegl1-mesa:amd64 is not configured yet.
 libegl1-mesa-drivers:amd64 depends on libwayland0 (>= 1.0.2); however:
  Package libwayland0:amd64 is not installed.

dpkg: error processing libegl1-mesa-drivers:amd64 (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libegl1-mesa-drivers-dbg:amd64:
 libegl1-mesa-drivers-dbg:amd64 depends on libegl1-mesa-drivers (= 9.2.3~brppa-0ubuntu1); however:
  Package libegl1-mesa-drivers:amd64 is not configured yet.

dpkg: error processing libegl1-mesa-drivers-dbg:amd64 (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgbm1:amd64:
 libgbm1:amd64 depends on libwayland0 (>= 1.0.2); however:
  Package libwayland0:amd64 is not installed.

dpkg: error processing libgbm1:amd64 (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgbm1-dbg:amd64:
 libgbm1-dbg:amd64 depends on libgbm1 (= 9.2.3~brppa-0ubuntu1); however:
  Package libgbm1:amd64 is not configured yet.

dpkg: error processing libgbm1-dbg:amd64 (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgbm-dev:
 libgbm-dev depends on libgbm1 (= 9.2.3~brppa-0ubuntu1); however:
  Package libgbm1:amd64 is not configured yet.
 libgbm-dev depends on libudev-dev; however:
  Package libudev-dev is not installed.

dpkg: error processing libgbm-dev (--install):
 dependency problems - leaving unconfigured
dpkg: error processing libgl1-mesa-dri:amd64 (--install):
 package libgl1-mesa-dri:amd64 9.2.3~brppa-0ubuntu1 cannot be configured because libgl1-mesa-dri:i386 is at a different version (9.2.1-1ubuntu3)
dpkg: error processing libgl1-mesa-dri:i386 (--install):
 package libgl1-mesa-dri:i386 9.2.1-1ubuntu3 cannot be configured because libgl1-mesa-dri:amd64 is at a different version (9.2.3~brppa-0ubuntu1)
dpkg: dependency problems prevent configuration of libgl1-mesa-dri-dbg:amd64:
 libgl1-mesa-dri-dbg:amd64 depends on libgl1-mesa-dri (= 9.2.3~brppa-0ubuntu1); however:
  Package libgl1-mesa-dri:amd64 is not configured yet.

dpkg: error processing libgl1-mesa-dri-dbg:amd64 (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgl1-mesa-dri-experimental:amd64:
 libgl1-mesa-dri-experimental:amd64 depends on libgl1-mesa-dri (>= 7.11.1); however:
  Package libgl1-mesa-dri:amd64 is not configured yet.

dpkg: error processing libgl1-mesa-dri-experimental:amd64 (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgl1-mesa-dri-experimental-dbg:amd64:
 libgl1-mesa-dri-experimental-dbg:amd64 depends on libgl1-mesa-dri-experimental (= 9.2.3~brppa-0ubuntu1); however:
  Package libgl1-mesa-dri-experimental:amd64 is not configured yet.

dpkg: error processing libgl1-mesa-dri-experimental-dbg:amd64 (--install):
 dependency problems - leaving unconfigured
dpkg: error processing libgl1-mesa-glx:amd64 (--install):
 package libgl1-mesa-glx:amd64 9.2.3~brppa-0ubuntu1 cannot be configured because libgl1-mesa-glx:i386 is at a different version (9.2.1-1ubuntu3)
dpkg: error processing libgl1-mesa-glx:i386 (--install):
 package libgl1-mesa-glx:i386 9.2.1-1ubuntu3 cannot be configured because libgl1-mesa-glx:amd64 is at a different version (9.2.3~brppa-0ubuntu1)
dpkg: dependency problems prevent configuration of libgl1-mesa-glx-dbg:amd64:
 libgl1-mesa-glx-dbg:amd64 depends on libgl1-mesa-glx (= 9.2.3~brppa-0ubuntu1); however:
  Package libgl1-mesa-glx:amd64 is not configured yet.

dpkg: error processing libgl1-mesa-glx-dbg:amd64 (--install):
 dependency problems - leaving unconfigured
dpkg: error processing libglapi-mesa:amd64 (--install):
 package libglapi-mesa:amd64 9.2.3~brppa-0ubuntu1 cannot be configured because libglapi-mesa:i386 is at a different version (9.2.1-1ubuntu3)
dpkg: error processing libglapi-mesa:i386 (--install):
 package libglapi-mesa:i386 9.2.1-1ubuntu3 cannot be configured because libglapi-mesa:amd64 is at a different version (9.2.3~brppa-0ubuntu1)
dpkg: dependency problems prevent configuration of libglapi-mesa-dbg:amd64:
 libglapi-mesa-dbg:amd64 depends on libglapi-mesa (= 9.2.3~brppa-0ubuntu1); however:
  Package libglapi-mesa:amd64 is not configured yet.

dpkg: error processing libglapi-mesa-dbg:amd64 (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgles1-mesa:amd64:
 libgles1-mesa:amd64 depends on libglapi-mesa (= 9.2.3~brppa-0ubuntu1); however:
  Package libglapi-mesa:amd64 is not configured yet.

dpkg: error processing libgles1-mesa:amd64 (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgles1-mesa-dbg:amd64:
 libgles1-mesa-dbg:amd64 depends on libgles1-mesa (= 9.2.3~brppa-0ubuntu1); however:
  Package libgles1-mesa:amd64 is not configured yet.

dpkg: error processing libgles1-mesa-dbg:amd64 (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgles1-mesa-dev:
 libgles1-mesa-dev depends on libgles1-mesa (= 9.2.3~brppa-0ubuntu1); however:
  Package libgles1-mesa:amd64 is not configured yet.
 libgles1-mesa-dev depends on libegl1-mesa-dev; however:
  Package libegl1-mesa-dev is not configured yet.

dpkg: error processing libgles1-mesa-dev (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgles2-mesa:amd64:
 libgles2-mesa:amd64 depends on libglapi-mesa (= 9.2.3~brppa-0ubuntu1); however:
  Package libglapi-mesa:amd64 is not configured yet.

dpkg: error processing libgles2-mesa:amd64 (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgles2-mesa-dbg:amd64:
 libgles2-mesa-dbg:amd64 depends on libgles2-mesa (= 9.2.3~brppa-0ubuntu1); however:
  Package libgles2-mesa:amd64 is not configured yet.

dpkg: error processing libgles2-mesa-dbg:amd64 (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgles2-mesa-dev:
 libgles2-mesa-dev depends on libgles2-mesa (= 9.2.3~brppa-0ubuntu1); however:
  Package libgles2-mesa:amd64 is not configured yet.
 libgles2-mesa-dev depends on libegl1-mesa-dev; however:
  Package libegl1-mesa-dev is not configured yet.

dpkg: error processing libgles2-mesa-dev (--install):
 dependency problems - leaving unconfigured
Setting up libopenvg1-mesa:amd64 (9.2.3~brppa-0ubuntu1) ...
Setting up libopenvg1-mesa-dbg:amd64 (9.2.3~brppa-0ubuntu1) ...
dpkg: dependency problems prevent configuration of libopenvg1-mesa-dev:
 libopenvg1-mesa-dev depends on libegl1-mesa-dev; however:
  Package libegl1-mesa-dev is not configured yet.

dpkg: error processing libopenvg1-mesa-dev (--install):
 dependency problems - leaving unconfigured
dpkg: error processing libosmesa6:amd64 (--install):
 package libosmesa6:amd64 9.2.3~brppa-0ubuntu1 cannot be configured because libosmesa6:i386 is at a different version (9.2.1-1ubuntu3)
dpkg: error processing libosmesa6:i386 (--install):
 package libosmesa6:i386 9.2.1-1ubuntu3 cannot be configured because libosmesa6:amd64 is at a different version (9.2.3~brppa-0ubuntu1)
dpkg: dependency problems prevent configuration of libosmesa6-dev:
 libosmesa6-dev depends on libosmesa6 (= 9.2.3~brppa-0ubuntu1); however:
  Package libosmesa6:amd64 is not configured yet.

dpkg: error processing libosmesa6-dev (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libxatracker1:amd64:
 libxatracker1:amd64 depends on libgl1-mesa-dri; however:
  Package libgl1-mesa-dri:amd64 is not configured yet.

dpkg: error processing libxatracker1:amd64 (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libxatracker1-dbg:amd64:
 libxatracker1-dbg:amd64 depends on libxatracker1 (= 9.2.3~brppa-0ubuntu1); however:
  Package libxatracker1:amd64 is not configured yet.

dpkg: error processing libxatracker1-dbg:amd64 (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libxatracker-dev:
 libxatracker-dev depends on libxatracker1 (= 9.2.3~brppa-0ubuntu1); however:
  Package libxatracker1:amd64 is not configured yet.

dpkg: error processing libxatracker-dev (--install):
 dependency problems - leaving unconfigured
Setting up linux-headers-3.11.8-031108 (3.11.8-031108.201311122252) ...
Setting up linux-headers-3.11.8-031108-generic (3.11.8-031108.201311122252) ...
Examining /etc/kernel/header_postinst.d.
run-parts: executing /etc/kernel/header_postinst.d/dkms 3.11.8-031108-generic /boot/vmlinuz-3.11.8-031108-generic
Setting up linux-image-3.11.8-031108-generic (3.11.8-031108.201311122252) ...
Running depmod.
update-initramfs: deferring update (hook will be called later)
Not updating initrd symbolic links since we are being updated/reinstalled 
(3.11.8-031108.201311122252 was configured last, according to dpkg)
Not updating image symbolic links since we are being updated/reinstalled 
(3.11.8-031108.201311122252 was configured last, according to dpkg)
Examining /etc/kernel/postinst.d.
run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 3.11.8-031108-generic /boot/vmlinuz-3.11.8-031108-generic
run-parts: executing /etc/kernel/postinst.d/dkms 3.11.8-031108-generic /boot/vmlinuz-3.11.8-031108-generic
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 3.11.8-031108-generic /boot/vmlinuz-3.11.8-031108-generic
update-initramfs: Generating /boot/initrd.img-3.11.8-031108-generic
run-parts: executing /etc/kernel/postinst.d/pm-utils 3.11.8-031108-generic /boot/vmlinuz-3.11.8-031108-generic
run-parts: executing /etc/kernel/postinst.d/update-notifier 3.11.8-031108-generic /boot/vmlinuz-3.11.8-031108-generic
run-parts: executing /etc/kernel/postinst.d/zz-extlinux 3.11.8-031108-generic /boot/vmlinuz-3.11.8-031108-generic
P: Checking for EXTLINUX directory... found.
P: Writing config for /boot/vmlinuz-3.9.4-030904-generic...
P: Writing config for /boot/vmlinuz-3.5.0-27-generic...
P: Writing config for /boot/vmlinuz-3.11.8-031108-generic...
P: Writing config for /boot/vmlinuz-3.11.0-12-generic...
P: Writing config for Windows 7 (loader) on /dev/sdb2...
P: Installing debian theme... done.
run-parts: executing /etc/kernel/postinst.d/zz-update-grub 3.11.8-031108-generic /boot/vmlinuz-3.11.8-031108-generic
Generating grub.cfg ...
Found linux image: /boot/vmlinuz-3.11.8-031108-generic
Found initrd image: /boot/initrd.img-3.11.8-031108-generic
Found linux image: /boot/vmlinuz-3.11.0-12-generic
Found initrd image: /boot/initrd.img-3.11.0-12-generic
Found linux image: /boot/vmlinuz-3.9.4-030904-generic
Found initrd image: /boot/initrd.img-3.9.4-030904-generic
Found linux image: /boot/vmlinuz-3.5.0-27-generic
Found initrd image: /boot/initrd.img-3.5.0-27-generic
Found memtest86+ image: /boot/memtest86+.bin
Found Windows 7 (loader) on /dev/sdb2
done
Setting up mesa-common-dev (9.2.3~brppa-0ubuntu1) ...
dpkg: dependency problems prevent configuration of libgl1-mesa-dev:
 libgl1-mesa-dev depends on libgl1-mesa-glx (= 9.2.3~brppa-0ubuntu1); however:
  Package libgl1-mesa-glx:amd64 is not configured yet.

dpkg: error processing libgl1-mesa-dev (--install):
 dependency problems - leaving unconfigured
Processing triggers for libc-bin ...
Errors were encountered while processing:
 libegl1-mesa:amd64
 libegl1-mesa-dbg:amd64
 libegl1-mesa-dev
 libegl1-mesa-drivers:amd64
 libegl1-mesa-drivers-dbg:amd64
 libgbm1:amd64
 libgbm1-dbg:amd64
 libgbm-dev
 libgl1-mesa-dri:amd64
 libgl1-mesa-dri:i386
 libgl1-mesa-dri-dbg:amd64
 libgl1-mesa-dri-experimental:amd64
 libgl1-mesa-dri-experimental-dbg:amd64
 libgl1-mesa-glx:amd64
 libgl1-mesa-glx:i386
 libgl1-mesa-glx-dbg:amd64
 libglapi-mesa:amd64
 libglapi-mesa:i386
 libglapi-mesa-dbg:amd64
 libgles1-mesa:amd64
 libgles1-mesa-dbg:amd64
 libgles1-mesa-dev
 libgles2-mesa:amd64
 libgles2-mesa-dbg:amd64
 libgles2-mesa-dev
 libopenvg1-mesa-dev
 libosmesa6:amd64
 libosmesa6:i386
 libosmesa6-dev
 libxatracker1:amd64
 libxatracker1-dbg:amd64
 libxatracker-dev
 libgl1-mesa-dev

I got scared that it was going to bork my system, so I tried to uninstall some with the following two commands (which didn't seem to do anything).

$ sudo apt-get purge libxatracker-dev libxatracker1-dbg:amd64 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies.
 libegl1-mesa : Depends: libwayland0 (>= 1.0.2) but it is not installable
 libegl1-mesa-drivers : Depends: libwayland0 (>= 1.0.2) but it is not installable
 libgbm-dev : Depends: libudev-dev but it is not going to be installed
 libgbm1 : Depends: libwayland0 (>= 1.0.2) but it is not installable
 libgl1-mesa-dri : Breaks: libgl1-mesa-dri:i386 (!= 9.2.3~brppa-0ubuntu1) but 9.2.1-1ubuntu3 is to be installed
 libgl1-mesa-dri:i386 : Breaks: libgl1-mesa-dri (!= 9.2.1-1ubuntu3) but 9.2.3~brppa-0ubuntu1 is to be installed
 libgl1-mesa-glx : Breaks: libgl1-mesa-glx:i386 (!= 9.2.3~brppa-0ubuntu1) but 9.2.1-1ubuntu3 is to be installed
 libgl1-mesa-glx:i386 : Breaks: libgl1-mesa-glx (!= 9.2.1-1ubuntu3) but 9.2.3~brppa-0ubuntu1 is to be installed
 libglapi-mesa : Breaks: libglapi-mesa:i386 (!= 9.2.3~brppa-0ubuntu1) but 9.2.1-1ubuntu3 is to be installed
 libglapi-mesa:i386 : Breaks: libglapi-mesa (!= 9.2.1-1ubuntu3) but 9.2.3~brppa-0ubuntu1 is to be installed
 libosmesa6 : Breaks: libosmesa6:i386 (!= 9.2.3~brppa-0ubuntu1) but 9.2.1-1ubuntu3 is to be installed
 libosmesa6:i386 : Breaks: libosmesa6 (!= 9.2.1-1ubuntu3) but 9.2.3~brppa-0ubuntu1 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
$ sudo apt-get -f purge libxatracker-dev libxatracker1-dbg:amd64 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies.
 libegl1-mesa : Depends: libwayland0 (>= 1.0.2) but it is not installable
 libegl1-mesa-drivers : Depends: libwayland0 (>= 1.0.2) but it is not installable
 libgbm-dev : Depends: libudev-dev but it is not going to be installed
 libgbm1 : Depends: libwayland0 (>= 1.0.2) but it is not installable
 libgl1-mesa-dri : Breaks: libgl1-mesa-dri:i386 (!= 9.2.3~brppa-0ubuntu1) but 9.2.1-1ubuntu3 is to be installed
 libgl1-mesa-dri:i386 : Breaks: libgl1-mesa-dri (!= 9.2.1-1ubuntu3) but 9.2.3~brppa-0ubuntu1 is to be installed
 libgl1-mesa-glx : Breaks: libgl1-mesa-glx:i386 (!= 9.2.3~brppa-0ubuntu1) but 9.2.1-1ubuntu3 is to be installed
 libgl1-mesa-glx:i386 : Breaks: libgl1-mesa-glx (!= 9.2.1-1ubuntu3) but 9.2.3~brppa-0ubuntu1 is to be installed
 libglapi-mesa : Breaks: libglapi-mesa:i386 (!= 9.2.3~brppa-0ubuntu1) but 9.2.1-1ubuntu3 is to be installed
 libglapi-mesa:i386 : Breaks: libglapi-mesa (!= 9.2.1-1ubuntu3) but 9.2.3~brppa-0ubuntu1 is to be installed
 libosmesa6 : Breaks: libosmesa6:i386 (!= 9.2.3~brppa-0ubuntu1) but 9.2.1-1ubuntu3 is to be installed
 libosmesa6:i386 : Breaks: libosmesa6 (!= 9.2.1-1ubuntu3) but 9.2.3~brppa-0ubuntu1 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

I then changed my mind again, and tried to install dependencies with

$ sudo apt-get -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  abiword-common evolution-data-server-common kate libaudio2:i386 libcamel-1.2-43 libclutter-1.0-common libcogl-common libdbusmenu-qt2:i386 libebook-contacts-1.2-0 libedataserver-1.2-17 libgdome2-cpp-smart0c2a
  libgtkmathview0c2a libicu48:i386 libkwinactiveeffects1abi4 liblcms1:i386 liblink-grammar4 libmng1:i386 libmysqlclient18:i386 libots0 libqt4-dbus:i386 libqt4-declarative:i386 libqt4-network:i386
  libqt4-script:i386 libqt4-sql:i386 libqt4-sql-mysql:i386 libqt4-xml:i386 libqt4-xmlpatterns:i386 libqtcore4:i386 libqtgui4:i386 libsdl-net1.2 libudev-dev libwayland-server0 libwv-1.2-4 libxss1:i386
  link-grammar-dictionaries-en sni-qt:i386
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  libudev-dev
The following packages will be REMOVED
  abiword abiword-plugin-grammar abiword-plugin-mathview gstreamer1.0-plugins-bad handbrake-gtk kde-window-manager kde-workspace kubuntu-desktop kubuntu-full libabiword-3.0 libchamplain-0.12-0
  libchamplain-gtk-0.12-0 libclutter-1.0-0 libclutter-gtk-1.0-0 libcogl-pango12 libcogl12 libegl1-mesa libegl1-mesa-dbg libegl1-mesa-dev libegl1-mesa-drivers libegl1-mesa-drivers-dbg libgbm-dev libgbm1
  libgbm1-dbg libgl1-mesa-dri:i386 libgl1-mesa-glx:i386 libglapi-mesa:i386 libgles1-mesa-dev libgles2-mesa-dev libglu1-mesa:i386 libgstreamer-plugins-bad1.0-0 libkwinglesutils1 libkwinglutils1abi3
  libopenvg1-mesa-dev libosmesa6:i386 libqt4-opengl:i386 libqtwebkit4:i386 libvisual-0.4-plugins:i386 skype skype-bin:i386 virtualgl-libs:i386 virtualgl-libs-ia32:i386 wine wine1.5 wine1.5-amd64
  wine1.5-i386:i386 wine1.6 wine1.6-amd64 wine1.6-i386:i386 xserver-xorg-glamoregl xserver-xorg-video-all xserver-xorg-video-ati
The following NEW packages will be installed
  libudev-dev
0 upgraded, 1 newly installed, 52 to remove and 83 not upgraded.
33 not fully installed or removed.
Need to get 27.0 kB of archives.
After this operation, 417 MB disk space will be freed.
Do you want to continue [Y/n]? n
Abort.

However, for some reason, things like Abiword were marked for uninstall. So:

  1. Why is Abiwork, etc. marked for uninstall?
  2. How would I revert this horrible half-installation?
  3. Is it possible to make this installation work (in an easily revertable fashion), or should I install mesa from source (and is that revertable)?
share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

Why is Abiwork, etc. marked for uninstall?

Wonders of apt-get. Under such circumstances (where the dependencies are broken and whatnot) is difficult to tell why apt-get is doing things. You can pass the -o Debug::pkgProblemResolver=true and see why apt-get is doing stuff trying to solve the dependencies. It will be very verbose, so for each reason you should ask for someone to explain each of them. I wouldn't follow apt-get advice since it could remove important packages and instead manually fixing the dependencies or using aptitude helps.

How would I revert this horrible half-installation?

Apart of reinstallation and never do that again (with that I mean manually installing almost core packages (mesa are) with dpkg -i)? You can do apt-cache policy against each name of the packages and force the versions. Example:

apt-cache policy libgl1-mesa-dri
libgl1-mesa-dri:
  Installed: 9.2.3~brppa-0ubuntu1
  Candidate: 9.1.7-1ubuntu2
  Version table:
 *** 9.2.3~brppa-0ubuntu1 0
        100 /var/lib/dpkg/status
     9.1.3-0ubuntu0.3 0
        500 http://archive.ubuntu.com/ubuntu/ raring-security/main amd64 Packages
     9.1.1-0ubuntu3 0
        500 http://archive.ubuntu.com/ubuntu/ raring/main amd64 Packages

sudo apt-get libgl1-mesa-dri=9.1.3-0ubuntu0.3

You need to do a list of packages (the ones you tried to install) and the nearest non-impossible-to-accomplish-dependency version and downgrade them at the same time. If you see any other package, you must manually fix them. aptitude also do this but GUI's are pretty stupid resolving dependencies.

Is it possible to make this installation work (in an easily revertable fashion), or should I install mesa from source (and is that revertable)?

Didn't you get the experience already? Use the package manager tools and repositories to make all your operations (specially if they are core packages like mesa) to assure you a problem free installation, and stop manually installing packages unless you are ready to reinstall. Said in a nutshell don't mess with your system if you are not ready to lose it. How to revert things is said in the previous block.

share|improve this answer
    
You replaced that package Preparing to replace libxatracker1:amd64 9.2.1-1ubuntu3 (using libxatracker1_9.2.3~brppa-0ubuntu1_amd64.deb) ... you replaced 9.2.1-1ubuntu3 with 9.2.3~brppa-0ubuntu1 so, there is a previous version... –  Braiam Nov 17 '13 at 22:33
    
No. Package names are uniques, also the :amd64 only refers to the architecture, nothing to do with the actual name of the package. The -dev says that the package has the development headers. The other is just a library. –  Braiam Nov 17 '13 at 22:42
    
As I vaguely hinted in the question, the reason why I was trying to manually install core packages was to try and overcome a particularly horrible bug that occurs multiple times a day (sometimes every few minutes when playing games), and renders most fonts in most applications immediately illegible. I worked out what the problem was, too. Firstly, I was using` apt-get purge` instead of dpkg --purge for the newly-selected packages. Secondly, one has to downgrade all the other packages simultaneously, otherwise dependency issues prevent it from completing. –  Sparhawk Nov 19 '13 at 23:01
1  
@Sparhawk you were trying to downgrade them one by one??? D: –  Braiam Nov 19 '13 at 23:11
    
Yes. Perhaps unclear, but that's what my second code block was saying. –  Sparhawk Nov 19 '13 at 23:20
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.