Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am attempting to package a simple video game for distribution on the Ubuntu Software Center. I have been working through the Ubuntu Packaging Guide Tutorial. I have succeeded in creating my GPG and SSH keys, getting them registered, getting set up with Launchpad, and registering the keys with Launchpad.

I skipped 1.3 - 1.5 Fixing Bugs (kdetoys) of the tutorial and went straight to 1.6 Packaging New Software (hello).

I was able to download the package, extract it, configure it, make it, and install it, such that the command hello now returns "Hello world!"

From there I ran bzr dh-make hello 2.9 hello-2.9.tar.gz which created a folder called "hello". I have made the suggested changes to the contents of the "hello" folder and committed the changes using bzr commit.

Then, when I run:

bzr builddeb -- -us -uc

It does a bunch of stuff and then I get:

dh clean 
   dh_testdir
   dh_auto_clean
make[1]: Entering directory /build-area/hello-2.9'
There seems to be no Makefile in this directory.
You must run ./configure before running 'make'.
make[1]: *** [abort-due-to-no-makefile] Error 1
make[1]: Leaving directory /build-area/hello-2.9'
dh_auto_clean: make -j1 distclean returned exit code 2
make: *** [clean] Error 29
dpkg-buildpackage: error: fakeroot debian/rules clean gave error exit status 2
debuild: fatal error at line 1350:
dpkg-buildpackage -rfakeroot -D -us -uc failed
bzr: ERROR: The build failed.

I am using Ubuntu 12.04 (32-bit). I have created a github repo of the "hello" folder in case anyone would be willing to peek at the changes I made to the package and see if I have configured something incorrectly.

Perhaps I need to install a component which I skipped in sections 1.3 - 1.5? Any suggestions will be appreciated.

share|improve this question

closed as off-topic by andrewsomething, guntbert, Seth, Warren Hill, Eric Carvalho Dec 8 '13 at 0:56

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Bug reports and problems specific to development version of Ubuntu should be reported on Launchpad so that developers can see, track and fix these issues." – andrewsomething, guntbert, Seth, Warren Hill, Eric Carvalho
If this question can be reworded to fit the rules in the help center, please edit the question.

    
This is a bug in the Packaging Guide itself. Work around for now, use version 2.7 instead of 2.9 for hello. (i.e. replace 2.9 with 2.7 in all the commands) See: bugs.launchpad.net/ubuntu-packaging-guide/+bug/1248353 Off to fix it now. Sorry! –  andrewsomething Dec 5 '13 at 23:41
    
Hey thanks I will try this! Good luck with the big fix! –  Matt Lemmon Dec 6 '13 at 1:31
    
...meant to say "bug fix" –  Matt Lemmon Dec 6 '13 at 23:30

Browse other questions tagged or ask your own question.