Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This question already has an answer here:

I've just bought a new Toshiba laptop, on which Windows 8 is preinstalled. I've installed Ubuntu Gnome 13.10 and GRUB2 correctly detects Ubuntu and Windows. But the strange problem is that when I try to boot Windows 8, it appears the following error:

file path:/ACPI(a0341d0,0)/PCI(2,1f)/UnknwnMessaging(12)/HD(2,200800,82000,a8d996409dcfe211,a8,59)/File(\EFI|Microsoft\Boot)/File(bootmgfw.efi)/EndEntire
error: cannot load image.

I've tried to solve using boot-repair, using the auto-correction. But never has changed. Here is the log generated by boot-repair:

How can I fix this?

share|improve this question

marked as duplicate by Rod Smith, Paranoid Panda, Tim, Eric Carvalho, Seth Jun 26 '15 at 23:04

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

Have you tried this:… – yjwong Nov 16 '13 at 16:27
If the output really was \EFI|Microsoft\Boot, then that may be the reason why the image couldn't be loaded (should be \EFI\Microsoft\Boot). I suspect boot-repair being responsible for this issue if there wasn't any other program involved with modifying Windows start up files. – LiveWireBT Jan 1 '15 at 4:32

This looks like bug #1091464. Turn off secure boot in the bios system under the section boot, and you should be able to boot Windows.

share|improve this answer
thank you for this answer, worked like a charm! ps: I have a lenovo y500 – sbenderli Mar 26 at 15:21

The suggestion to try this solution is a good one, and Dillmo's suggestion might work, too. I have three other suggestions, though:

  • This problem can sometimes be caused by a failure to disable the Windows Fast Startup feature. Note that this is not the same as the "fast boot" feature in the firmware. If left enabled, Fast Startup can cause filesystem corruption and an inability to read files in shared filesystems, including in the ESP, where boot loaders are stored. Of course, if you can't boot Windows, you won't be able to disable this feature, which puts you in a conundrum. Either of the following two suggestions might help get you out of that conundrum, though....
  • You could try using my rEFInd boot manager. There are USB flash drive and CD-R images on its download page, so you can try it risk-free, without installing it to your hard disk. It's possible that rEFInd will be able to launch the Windows boot loader even when GRUB can't. You could then either switch to rEFInd by installing the Debian-package version or at least use its ability to boot Windows to disable Fast Startup. Note that rEFInd is likely to show two Windows options. Try them both.
  • Based on your error message, it looks like you're using the Windows Boot Manager (UEFI on /dev/sda2) GRUB option. Instead, try the Windows UEFI bkpbootmgfw.efi option; it might work better.
share|improve this answer

Your problem is probably a broken path to the Windows UEFI file. To fix this, follow these instructions.

  1. Boot into Ubuntu.
  2. Start up a Terminal emulator with Ctrl+Alt+T
  3. Run the command, sudo update-grub
  4. Reboot. Hopefully, GRUB updated it's configuration to the correct path of the Windows UEFI file.
share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.