Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've just bought a new laptop Toshiba, on which there is Windows 8 preinstalled. I've installed Ubuntu Gnome 13.10 and Grub2 detects correctly Ubuntu and Windows. But the strange problem is that when I try to boot Windows 8, it appears the following error:

/EndEntire
file path:/ACPI(a0341d0,0)/PCI(2,1f)/UnknwnMessaging(12)/HD(2,200800,82000,a8d996409dcfe211,a8,59)/File(\EFI|Microsoft\Boot)/File(bootmgfw.efi)/EndEntire
error: cannot load image.

I've tried to solve using boot-repair, using the auto-correction. But never has changed. Here is the log generated by boot-repair: http://paste.ubuntu.com/6426642/. How can I fix this?

share|improve this question
1  
Have you tried this: askubuntu.com/questions/280339/… –  yjwong Nov 16 '13 at 16:27

3 Answers 3

Your problem is probably a broken path to the Windows UEFI file. To fix this, follow these instructions.

  1. Boot into Ubuntu.
  2. Start up a Terminal emulator with Ctrl+Alt+T
  3. Run the command, sudo update-grub
  4. Reboot. Hopefully, GRUB updated it's configuration to the correct path of the Windows UEFI file.
share|improve this answer

The suggestion to try this solution is a good one, and Dillmo's suggestion might work, too. I have three other suggestions, though:

  • This problem can sometimes be caused by a failure to disable the Windows Fast Startup feature. Note that this is not the same as the "fast boot" feature in the firmware. If left enabled, Fast Startup can cause filesystem corruption and an inability to read files in shared filesystems, including in the ESP, where boot loaders are stored. Of course, if you can't boot Windows, you won't be able to disable this feature, which puts you in a conundrum. Either of the following two suggestions might help get you out of that conundrum, though....
  • You could try using my rEFInd boot manager. There are USB flash drive and CD-R images on its download page, so you can try it risk-free, without installing it to your hard disk. It's possible that rEFInd will be able to launch the Windows boot loader even when GRUB can't. You could then either switch to rEFInd by installing the Debian-package version or at least use its ability to boot Windows to disable Fast Startup. Note that rEFInd is likely to show two Windows options. Try them both.
  • Based on your error message, it looks like you're using the Windows Boot Manager (UEFI on /dev/sda2) GRUB option. Instead, try the Windows UEFI bkpbootmgfw.efi option; it might work better.
share|improve this answer

This looks like bug #1091464. Turn off secure boot, and you should be able to boot Windows.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.