Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

this is what I get lately when I try to update. New with Ubuntu and I've messing around with almost everything lately.. no sure what i did before that, and although i does not look important and i am unable to fix it by myself.

any ideas?

thanks!

W: Duplicate sources.list entry ttp://security.ubuntu.com/ubuntu/ precise-security/restricted amd64 Packages (/var/lib/apt/lists/security.ubuntu.com_ubuntu_dists_precise-security_restricted_binary-amd64_Packages)
W: Duplicate sources.list entry ttp://security.ubuntu.com/ubuntu/ precise-security/main amd64 Packages (/var/lib/apt/lists/security.ubuntu.com_ubuntu_dists_precise-security_main_binary-amd64_Packages)
W: Duplicate sources.list entry ttp://security.ubuntu.com/ubuntu/ precise-security/multiverse amd64 Packages (/var/lib/apt/lists/security.ubuntu.com_ubuntu_dists_precise-security_multiverse_binary-amd64_Packages)
W: Duplicate sources.list entry ttp://security.ubuntu.com/ubuntu/ precise-security/universe amd64 Packages (/var/lib/apt/lists/security.ubuntu.com_ubuntu_dists_precise-security_universe_binary-amd64_Packages)
W: Duplicate sources.list entry ttp://security.ubuntu.com/ubuntu/ precise-security/restricted i386 Packages (/var/lib/apt/lists/security.ubuntu.com_ubuntu_dists_precise-security_restricted_binary-i386_Packages)
W: Duplicate sources.list entry http://security.ubuntu.com/ubuntu/ precise-security/main i386 Packages (/var/lib/apt/lists/security.ubuntu.com_ubuntu_dists_precise-security_main_binary-i386_Packages)
W: Duplicate sources.list entry ttp://security.ubuntu.com/ubuntu/ precise-security/multiverse i386 Packages (/var/lib/apt/lists/security.ubuntu.com_ubuntu_dists_precise-security_multiverse_binary-i386_Packages)
W: Duplicate sources.list entry ttp://security.ubuntu.com/ubuntu/ precise-security/universe i386 Packages (/var/lib/apt/lists/security.ubuntu.com_ubuntu_dists_precise-security_universe_binary-i386_Packages)
W: You may want to run apt-get update to correct these problems
share|improve this question

marked as duplicate by Rinzwind, Aditya, Warren Hill, Roman Raguet, guntbert Nov 17 '13 at 21:37

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
duplicated of askubuntu.com/q/120621/169736 –  Braiam Nov 16 '13 at 14:26

2 Answers 2

Thats it self saying the problem.

in your sources.list you have the repeated entries and you best remove them. so that you can avoid the error.

to open that file type

sudo gedit /etc/apt/sources.list

Then find those repeated entries and remove them. after removing them , save & close the file.

Then run sudo apt-get update

again.

hope that helps.

share|improve this answer
    
Wonderful!Thanks! –  user216362 Nov 16 '13 at 14:31
    
@user216362 could you please accept the answer. –  AgentCool Nov 16 '13 at 16:08

Try this:

sudo rm -rvf /var/lib/apt/lists/*

And then, update again:

sudo apt-get update
share|improve this answer
    
Hey your answer is suitable for index fixing and this is not index crash issue and it cant help the O{ problem. –  AgentCool Nov 16 '13 at 14:02
    
Unfortunately I did not work. –  user216362 Nov 16 '13 at 14:27

Not the answer you're looking for? Browse other questions tagged or ask your own question.