Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm using Ubuntu 12.04. I have a problem with my wifi, but not always. My system detects wifi networks some times and display it in the available wifi networks list and is able to connect properly. But, some times it doesn't detect available wifi networks at all.

Can any tell me a way to make Ubuntu look for available wifi networks?

Here is the iwconfig info

ppp0      no wireless extensions.

lo        no wireless extensions.

wwan0     no wireless extensions.

eth1      IEEE 802.11abg  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off

eth0      no wireless extensions.

Result of lspci is

Network controller: Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller (rev 01)
share|improve this question
Be clear about the problem. Is Ubuntu not showing them even though they are present? – krishna kaanthh Nov 16 '13 at 14:16
Post the output iwconfig from terminal – krishna kaanthh Nov 16 '13 at 14:23
posted the iwconfig – iJade Nov 16 '13 at 14:26
Is right now detecting networks? Have you connected an usb dongle? Is reproducible the problem? – Braiam Nov 16 '13 at 14:33
no its still not detecting wifi networks.Yes i have connected a usb dongle – iJade Nov 16 '13 at 14:35

Open a terminal. Type the following:

sudo crontab -e  

Now type the following:

* * * * * iwlist eth1 scan  

Save it and exit.

share|improve this answer
i already tried dat on cmd prompt shows "eth1 No scan results" – iJade Nov 16 '13 at 14:39

Use this in terminal

   sudo lsmod | grep ipw2200

If it returns some lines then it will ensure that the driver is loaded perfectly or else you have to contact Ubuntu Forms Or else try this:

open the ‘Synaptic Package Manager‘ (if you are using Ubuntu 11.10 then install it first from the software cemter) and search for ‘bcm’ uninstall the ‘bcm-kernel-source‘ package make sure that the ‘firmware-b43-installer‘ and the ‘b43-fwcutter‘ packages are installed type into terminal:

cat /etc/modprobe.d/* | egrep '8180|acx|at76|ath|b43|bcm|CX|eth|ipw|irmware|isl|lbtf|orinoco|ndiswrapper|NPE|p54|prism|rtl|rt2|rt3|rt6|rt7|witch|wl' 

(you may want to copy this till the end if it is not visible properly) and see if the term ‘blacklist bcm43xx‘ is there

if it is, then type cd /etc/modprobe.d/ and then sudo gedit blacklist.conf put a # in front of the line: blacklist bcm43xx then save the file (I was getting error messages in the terminal about not being able to save, but it actually did save properly). reboot

share|improve this answer
but my network controller is Network controller: Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller and not Network controller: Intel Corporation PRO/Wireless 2200BG – iJade Nov 16 '13 at 14:57

Use iwlist. The man page (actually says:

Provided by: wireless-tools_30~pre9-8ubuntu1_i386


       iwlist  -  Get  more  detailed  wireless  information  from  a wireless


       iwlist [interface] scanning



              Give the list of Access Points and Ad-Hoc cells  in  range,  and
              optionally  a  whole  bunch  of  information  about them (ESSID,
              Quality, Frequency, Mode...). The type of  information  returned
              depends on what the card supports.
              Triggering  scanning  is  a privileged operation (root only) and
              normal users can only read left-over scan results.  By  default,
              the way scanning is done (the scope of the scan) is dependant on
              the card and card settings.
              This command takes optional arguments, however most drivers will
              ignore  those.  The  option essid is used to specify a scan on a
              specific ESSID. With  some  card/driver,  this  enables  to  see
              hidden  networks.  The  option  last does not trigger a scan and
              read left-over scan results.
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.