Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I upgraded from Ubuntu 10.10 to Ubuntu 11.04 and now my touchpad doesn't work. Please explain how to fix it thoroughly, because I'm a newbie. Thanks

share|improve this question
    
Nevermind. I fixed it. –  Joshua Branson Apr 30 '11 at 4:19
    
I just copied into the terminal 1) sudo gedit /etc/X11/xorg.conf –  Joshua Branson Apr 30 '11 at 4:20
    
And then 2) I edited what I already had on the file: Section "InputClass" Identifier "enable synaptics SHMConfig" MatchIsTouchpad "on" MatchDevicePath "/dev/input/event*" Option "SHMConfig" "on" EndSection –  Joshua Branson Apr 30 '11 at 4:21

1 Answer 1

Had the same problem upgrading from ubuntu 10.10 to 11.04. I used the Synaptic drivers in 10.10, but the solution that worked the best for me was to REMOVE all mention of the Synaptics Touchpad diver and Device settings for the touchpad from the xorg.conf file. Rebooted and the Touchpad worked perfectly with the default ubuntu touchpad drivers. The settings also appear under the mouse settings for the touchpad by default after install on the MBP 7,1

The same holds true for the Apple Magic Trackpad used with Ubuntu 11.04. It works perfectly out of the box with multi finger gestures.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.