Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm working in Ubuntu 10.10 and am trying to start a single node cluster in Hadoop.

hadoop@abraham-Dimension-3000:/usr/local/hadoop$ bin/start-all.sh
mkdir: cannot create directory `/usr/local/hadoop/bin/../logs': Permission denied
starting namenode, logging to /usr/local/hadoop/bin/../logs/hadoop-hadoop-namenode-abraham-Dimension-3000.out
/usr/local/hadoop/bin/hadoop-daemon.sh: line 117: /usr/local/hadoop/bin/../logs/hadoop-hadoop-namenode-abraham-Dimension-3000.out: No such file or directory
head: cannot open `/usr/local/hadoop/bin/../logs/hadoop-hadoop-namenode-abraham-Dimension-3000.out' for reading: No such file or directory
localhost: mkdir: cannot create directory `/usr/local/hadoop/bin/../logs': Permission denied
localhost: starting datanode, logging to /usr/local/hadoop/bin/../logs/hadoop-hadoop-datanode-abraham-Dimension-3000.out
localhost: /usr/local/hadoop/bin/hadoop-daemon.sh: line 117: /usr/local/hadoop/bin/../logs/hadoop-hadoop-datanode-abraham-Dimension-3000.out: No such file or directory
localhost: head: cannot open `/usr/local/hadoop/bin/../logs/hadoop-hadoop-datanode-abraham-Dimension-3000.out' for reading: No such file or directory
localhost: mkdir: cannot create directory `/usr/local/hadoop/bin/../logs': Permission denied
localhost: starting secondarynamenode, logging to /usr/local/hadoop/bin/../logs/hadoop-hadoop-secondarynamenode-abraham-Dimension-3000.out
localhost: /usr/local/hadoop/bin/hadoop-daemon.sh: line 117: /usr/local/hadoop/bin/../logs/hadoop-hadoop-secondarynamenode-abraham-Dimension-3000.out: No such file or directory
localhost: head: cannot open `/usr/local/hadoop/bin/../logs/hadoop-hadoop-secondarynamenode-abraham-Dimension-3000.out' for reading: No such file or directory
mkdir: cannot create directory `/usr/local/hadoop/bin/../logs': Permission denied
starting jobtracker, logging to /usr/local/hadoop/bin/../logs/hadoop-hadoop-jobtracker-abraham-Dimension-3000.out
/usr/local/hadoop/bin/hadoop-daemon.sh: line 117: /usr/local/hadoop/bin/../logs/hadoop-hadoop-jobtracker-abraham-Dimension-3000.out: No such file or directory
head: cannot open `/usr/local/hadoop/bin/../logs/hadoop-hadoop-jobtracker-abraham-Dimension-3000.out' for reading: No such file or directory
localhost: mkdir: cannot create directory `/usr/local/hadoop/bin/../logs': Permission denied
localhost: starting tasktracker, logging to /usr/local/hadoop/bin/../logs/hadoop-hadoop-tasktracker-abraham-Dimension-3000.out
localhost: /usr/local/hadoop/bin/hadoop-daemon.sh: line 117: /usr/local/hadoop/bin/../logs/hadoop-hadoop-tasktracker-abraham-Dimension-3000.out: No such file or directory
localhost: head: cannot open `/usr/local/hadoop/bin/../logs/hadoop-hadoop-tasktracker-abraham-Dimension-3000.out' for reading: No such file or directory
hadoop@abraham-Dimension-3000:/usr/local/hadoop$ 

I have no clue what I'm doing wrong or what some of these errors suggest.

hadoop@abraham-Dimension-3000:/usr/local/hadoop$ jps
5099 Jps

Can anyone with diagnosing the problem.

share|improve this question
up vote 12 down vote accepted

The errors suggest a permissions problem.

Make sure that the hadoop user has the proper privileges to /usr/local/hadoop. Try:

sudo chown -R hadoop /usr/local/hadoop/
share|improve this answer
    
I spent few hours trying to figure out what settings should I change to make my hadoop work. And finally I found solution which works for me. Thank you! :) – tyskaj Dec 23 '15 at 9:29

you specified the working directory for hadoop file system with other than the hadoop user, so set the directory which has read, write permissions to hadoop user or change the ower of the directory
Try ::

sudo chown -R hadoop-user /user/hadoop_project/

or

sudo chmod 777 /user/hadoop_project

where 'hadoop-user' login name for hadoop envirnoment . 'hadoop-project' specified working directory for hadoop file system. (specify your own login and directory that you are using for hadoop installation)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.