Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Last week I bought a thinkpad T430 with a 500GB HDD and added a 128GB SSD to it. Then I installed Ubuntu on the SSD and I'm using it, while there is a Windows8 pre-installed on the HDD and I never used and never will use it. I want to turn the HDD completely off, because when it is turned on, it decreases the battery life and also it makes some noises (standard spinning sound of HDD). I tried removing the related fstab entries, but it doesn't turned off even in the next boot.

Is there any solution to turn off the HDD without opening the laptop and removing it physically?

share|improve this question
1  
Before you completely turn off that HDD you should make sure that you dont boot from it, and that you dont have your BIOS on it. –  Takkat Nov 16 '13 at 8:34
add comment

2 Answers

up vote 2 down vote accepted

Try something like sudo hdparm -B 127 -Y /dev/sdb, assuming /dev/sdb is the HDD.

If that works, you can experiment with the /etc/hdparm.conf settings to enable aggressive power management on the HDD, put it to sleep/standby quickly, and turn the power off.

The file is well commented, and has a few examples. Also check out man hdparm for better understanding of the options.

Something like the following should quickly put the HDD to sleep:

/dev/disk/by-id/...{
    apm = 127
    sleep
}

To properly identify the HDD in /dev/disk/by-id/ look at the output of
sudo hdparm /dev/sdb | head

share|improve this answer
    
Thanks a lot! hdparm command did the work! I edited the hdparm.conf file and will post the final result whenever I rebooted the laptop ;) –  Danial Behzadi Nov 16 '13 at 20:30
    
Glad it worked for you, and thanks for accepting the answer. –  mikewhatever Nov 17 '13 at 20:12
add comment

Check your /etc/fstab file for the line containing your windows partition(s) and comment those out so they no longer automount at startup, although they SHOULD still appear in the list of devices at the side in Nautilus but require a password to mount...

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.