Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've got a 2nd generation Intel i5 processor with integrated graphics. In live usb mode, Ubuntu uses this one and Unity works fine. After installation with automatical updates and 3rd party software installation, I can't use Unity, and Ubuntu seems to use the nVidia grahpics card. Though Jockey tells me the driver would be activated but not in use.

Right after Login, it tells me I lack 3d support for Compiz. After removing the driver, Unity works again. Even after installing the Nouveau driver it works. I'd be really happy if someone could tell me why that happens and how I'm able to use Unity with the official nVidia driver, because it still is much better than Nouveau.

share|improve this question
    
Seems like this might be relevant to your interests. Let me know if it works and I'll close this as a duplicate. –  Oli Apr 28 '11 at 23:29
    
not really, since his problem is his graphics card being too old... if anything, mine is too new ;D edit: aww sorry, didn't read properly... let me try –  axle Apr 28 '11 at 23:33
    
Yeah I think the problem is the same though: Unity has it blacklisted. Try the answer (forcing Unity). –  Oli Apr 28 '11 at 23:34
    
sorry, but this didn't work. It loaded classic ubuntu :/ –  axle Apr 28 '11 at 23:38
    
this might end up being something that should be filed as a bug report. –  Jorge Castro Apr 29 '11 at 0:51
show 1 more comment

3 Answers

The support for Nvidia Optimus under Linux isn't that bad these days. Have a look at this website, which explains how bumblebee allows to have a hybrid system working with both the integrated and discrete graphics card at the same time: http://launchpad.net/~hybrid-graphics-linux

share|improve this answer
add comment

The Sandy Bridge system with a NVIDIA 410M graphics seems to be a laptop with NVIDIA Optimus technology. If so, you should not even try to install the restricted drivers from NVIDIA, they are unlikely to help.

Lookup up other notes around here and you will find that Optimus is not supported on Ubuntu yet. The only system I know which will work with it is Windows 7.

Would be useful if you gave the exact laptop brand and model -- and, recheck if it specs Optimus.

share|improve this answer
    
You're right, it is a Lenovo Z370 with Optimus technology. It' a pretty new laptop, so I was glad Ubuntu supported it at all :). Windows was preinstalled and worked fine indeed. Too bad that Ubuntu does not yet :/ Thanks though for you answer. –  axle Apr 30 '11 at 12:29
    
@axle, also see askubuntu.com/q/36930/1352 –  nik May 5 '11 at 14:14
add comment

try the steps in this blog - installing-hardware-drivers-in-ubuntu and if its still not working get unity-2d from software centre (its almost like unity-3d but based on qt and is most likely will be the default in 11.10) and login using unity-2d!

share|improve this answer
    
Driver is installed correctly, thanks though. Actually I don't like Qt that much, so I would like to avoid any contact :P. Also it has to be possible to use the normal Unity with my driver, and I'd appreciate that a lot :). –  axle Apr 28 '11 at 23:44
    
It is recommended that you do not try to install NVIDIA drivers on Optimus based systems. –  nik May 5 '11 at 14:10
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.