Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Why does terminal open up in documents? For example, I opened the terminal and it says:

cyberproxy@Paradox: ~/Documents. 

Why is that the default location? Can't do anything that way.

My ~/.bashrc file is:

# ~/.bashrc: executed by bash(1) for non-login shells.
# see /usr/share/doc/bash/examples/startup-files (in the package bash-doc)
# for examples

# If not running interactively, don't do anything
[ -z "$PS1" ] && return

# don't put duplicate lines or lines starting with space in the history.
# See bash(1) for more options

# append to the history file, don't overwrite it
shopt -s histappend

# for setting history length see HISTSIZE and HISTFILESIZE in bash(1)

# check the window size after each command and, if necessary,
# update the values of LINES and COLUMNS.
shopt -s checkwinsize

# If set, the pattern "**" used in a pathname expansion context will
# match all files and zero or more directories and subdirectories.
#shopt -s globstar

# make less more friendly for non-text input files, see lesspipe(1)
[ -x /usr/bin/lesspipe ] && eval "$(SHELL=/bin/sh lesspipe)"

# set variable identifying the chroot you work in (used in the prompt below)
if [ -z "$debian_chroot" ] && [ -r /etc/debian_chroot ]; then
    debian_chroot=$(cat /etc/debian_chroot)

# set a fancy prompt (non-color, unless we know we "want" color)
case "$TERM" in
    xterm-color) color_prompt=yes;;

# uncomment for a colored prompt, if the terminal has the capability; turned
# off by default to not distract the user: the focus in a terminal window
# should be on the output of commands, not on the prompt

if [ -n "$force_color_prompt" ]; then
    if [ -x /usr/bin/tput ] && tput setaf 1 >&/dev/null; then
    # We have color support; assume it's compliant with Ecma-48
    # (ISO/IEC-6429). (Lack of such support is extremely rare, and such
    # a case would tend to support setf rather than setaf.)

if [ "$color_prompt" = yes ]; then
    PS1='${debian_chroot:+($debian_chroot)}\[\033[01;32m\]\u@\h\[\033[00m\]:\[\033[01;34m\]\w\[\033[00m\]\$ '
    PS1='${debian_chroot:+($debian_chroot)}\u@\h:\w\$ '
unset color_prompt force_color_prompt

# If this is an xterm set the title to user@host:dir
case "$TERM" in
    PS1="\[\e]0;${debian_chroot:+($debian_chroot)}\u@\h: \w\a\]$PS1"

# enable color support of ls and also add handy aliases
if [ -x /usr/bin/dircolors ]; then
    test -r ~/.dircolors && eval "$(dircolors -b ~/.dircolors)" || eval "$(dircolors -b)"
    alias ls='ls --color=auto'
    #alias dir='dir --color=auto'
    #alias vdir='vdir --color=auto'

    alias grep='grep --color=auto'
    alias fgrep='fgrep --color=auto'
    alias egrep='egrep --color=auto'

# some more ls aliases
alias ll='ls -alF'
alias la='ls -A'
alias l='ls -CF'

# Add an "alert" alias for long running commands.  Use like so:
#   sleep 10; alert
alias alert='notify-send --urgency=low -i "$([ $? = 0 ] && echo terminal || echo error)" "$(history|tail -n1|sed -e '\''s/^\s*[0-9]\+\s*//;s/[;&|]\s*alert$//'\'')"'

# Alias definitions.
# You may want to put all your additions into a separate file like
# ~/.bash_aliases, instead of adding them here directly.
# See /usr/share/doc/bash-doc/examples in the bash-doc package.

if [ -f ~/.bash_aliases ]; then
    . ~/.bash_aliases

# enable programmable completion features (you don't need to enable
# this, if it's already enabled in /etc/bash.bashrc and /etc/profile
# sources /etc/bash.bashrc).
if [ -f /etc/bash_completion ] && ! shopt -oq posix; then
    . /etc/bash_completion
share|improve this question

closed as off-topic by chaskes, Mateo, Braiam, Eric Carvalho, karel Nov 17 '13 at 1:23

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This is not about Ubuntu. Questions about other Linux distributions can be asked on Unix & Linux, those about Windows on Super User, those about Apple products on Ask Different and generic programming questions on Stack Overflow." – chaskes, Mateo, Braiam, Eric Carvalho, karel
If this question can be reworded to fit the rules in the help center, please edit the question.

How are you opening terminal? –  Mitch Nov 15 '13 at 16:53
Panel --> Terminal. –  user212085 Nov 15 '13 at 16:54
Using gedit ~/.bashrc on a terminal. –  i08in Nov 15 '13 at 17:43
Let's back up for a second. The image you linked to shows that you are using Ultimate Edition, which is off-topic. Aside from that, how was the user created? For all we know, Documents was set as the home dir. grep "username" /etc/passwd wo;; show what your home dir should be. Also, your username has proxy in it. Is that just your preference or are you by chance logging into a remote system where things were set up this way? –  chaskes Nov 15 '13 at 18:43
Close voters, the OP is using Ultimate Edition. –  chaskes Nov 15 '13 at 18:44

1 Answer 1

The problem is not in the ~/.bashrc file as I can see, but I'm sure that is somewhere in bash initialization files. More than likely, somewhere the home directory (~) is changing to ~/Documents.

Now, I know that this is not the best fix, but you can solve the problem for now by adding the following line at the end of your ~/.bashrc file (you can open this file for editing with gedit ~/.bashrc file):

cd ~

Yes, only this. Don't forget to save the file and close it, then restart your terminal.

share|improve this answer
Isn't this a cover-up to the problem? –  i08in Nov 15 '13 at 18:05
@Jobin Exactly, this is what I wanted to say with "I know that this is not the best fix, but you can solve the problem for now". –  Radu Rădeanu Nov 15 '13 at 18:09
+1 for listing all bash-initialization files :) –  i08in Nov 15 '13 at 18:10
@user212085: Please accept the answer if it has solved your problem. –  i08in Nov 15 '13 at 18:27
Thanks. So basically, what exactly am I doing to fix this problem? –  user212085 Nov 15 '13 at 19:11

Not the answer you're looking for? Browse other questions tagged or ask your own question.