Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed ffmpeg completely from this Guide. I installed Winff in Ubuntu but when I want to try convert I face to this error:

ffmpeg version git-2013-11-15-995f450 Copyright (c) 2000-2013 the FFmpeg developers
  built on Nov 15 2013 18:32:56 with gcc 4.8 (Ubuntu/Linaro 4.8.1-10ubuntu8)
  configuration: --disable-yasm
  libavutil      52. 53.100 / 52. 53.100
  libavcodec     55. 43.100 / 55. 43.100
  libavformat    55. 21.100 / 55. 21.100
  libavdevice    55.  5.100 / 55.  5.100
  libavfilter     3. 91.100 /  3. 91.100
  libswscale      2.  5.101 /  2.  5.101
  libswresample   0. 17.104 /  0. 17.104
Unrecognized option 'preset'.
Error splitting the argument list: Option not found
Press Enter to Continue

...I installed libavcodec-extra-53 also..what's soution?

share|improve this question
    
How you call Winff? –  Braiam Nov 15 '13 at 12:32
add comment

2 Answers 2

You didn't follow the guide properly because your ffmpeg configure only contains --disable-yasm. The presets are probably for encoding with libx264, but since your ffmpeg configure is lacking --enable-gpl --enable-libx264 you do not have support for this encoder.

The libavcodec-extra-53 package will not affect your compiled ffmpeg, so it does nothing in this case.

share|improve this answer
    
so how I enable Yasm in ffmpeg? –  Deniz Nov 16 '13 at 8:03
    
@Deniz See How to Compile FFmpeg on Ubuntu. –  LordNeckbeard Nov 16 '13 at 19:57
    
Its that linked I followed how to compile ffmpeg..I didnot have problem in Ubuntu 12.04 but in new, Ubutu 13.10 I have problem.. –  Deniz Nov 17 '13 at 9:25
    
@Deniz The guide installs yasm and does not use --disable-yasm. What is the problem, exactly? –  LordNeckbeard Nov 17 '13 at 20:38
add comment

I am having the same issue. The answer is simple. Look at the version number of your libavcodec. It's 55. However the most recent presets on the WinFF website are for version 54.

Until winf posts new presets your only choice is to use a different ffmpeg or play with the presets till you find a combination that works. I tried but the output is horrible.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.