Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am new learner of blender3D. I installed Ubuntu two days ago, and was struggling installing my nvidia and blender on new OS. After more than 15 times fresh installation and following help forum I was able to install but now I have a problem.

My Preference > System dose not show GPU option, ( Once it woked yesterday but I ruined my installation trying to fix left mouse button issue).

I am very new to linux, I know nothing about it.

How can I fix this issue ?

What I want to achieve is run blender and get the utmost performance of my hardware on Linux Ubuntu

Details of PC : i7 processor, with Nvidia 640 graphic card.

Things I have done are:

Fresh install of Ubuntu and then installation of Nvidia driver

sudo apt-get install nvidia-current

Then I installed blender

sudo add-apt-repository ppa:irie/blender
sudo apt-get update
sudo apt-get install blender

So, now my blender is working, but in the system preference it shows NO CPU and when I go to render view, I don't see the environment texture. Only green and gray colors at back ground. I am in doubt weather if my Nvidia is properly installed, or cuda installation is must to be done.

share|improve this question
    
Take a look at this question: How to enable GPU rendering on older Nvidia GPUs? about the same topic as your question. He has an Nvidia graphics card and he wants to use Blender Cycles for GPU rendering. –  karel Nov 25 '13 at 4:50
add comment

1 Answer 1

i found the problem. now my GPU Rendering is working with one exception. the problem was Blender package in Repository. someone asked me to install from the main site and now it works, exception is that it's not fast enough. CPU is faster.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.