Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just upgraded from Maverick to Natty. My main account still runs Firefox 3.6. However, I know that Firefox 4 is installed, because I created a new user and it runs Firefox 4.

How do I get my main user account to run Firefox 4 from Unity?

Thanks, Tim

share|improve this question
up vote 1 down vote accepted

Sorry about not adding my solution. I tried several times, but I was fighting with the stupid captcha applet.

Anyway, I discovered that there was an old, manually installed Firefox 3.6 in /opt/firefox. This is what the icon was trying to start. I deleted that folder, then the icon wouldn't start anything.

So, I uninstalled and reinstalled FF 4 using aptitude. Then, I found that I could start FF 4 from the terminal, but the icon was still looking for /opt/firefox.

I could not find out how to fix that in Unity, so I logged into Gnome Classic and changed the Properties of both the icon and the menu item for Firefox. Then, when I logged back into Unity, the icon worked.


share|improve this answer

First method

Super+A, type system, click on System Settings -> Personal section -> Preferred Applications -> Internet tab -> Web Browser, choose Firefox Web Browser.

Second method

Alt+F2, type firefox, hit ENTER, from menu Edit -> Preferences, Advanced -> General Tab -> System Defaults, click on Check Now, click on Yes, click on Close.

share|improve this answer
Thanks for the suggestions, Vanni, but I tried it both ways you gave, and my primary user still runs FF 3.6. – Tim Apr 29 '11 at 0:40
I finally solved the problem. I don't know if it was the best way, but it worked. – Tim Apr 29 '11 at 2:10
@Tim: what was your solution? – Vanni Totaro Apr 30 '11 at 2:30

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.