Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

In my Ubuntu 13.10 system, I tried to install Canon Pixma IP2770 with the following command:

sudo add-apt-repository ppa:michael-gruz/canon

sudo apt-get update

sudo apt-get install cnijfilter-ip2700series

Then I get the following error messages like this:

cnijfilter-common:i386 : Depends: libpopt0:i386 (>= 1.7) but it is not going to be installed
cnijfilter-ip2700series:i386 : Depends: libatk1.0-0:i386 (>= 1.9.0) but it is not going to be installed
                               Depends: libcairo2:i386 (>= 1.0.2-2) but it is not going to be installed
                               Depends: libgtk2.0-0:i386 (>= 2.8.0) but it is not going to be installed
                               Depends: libpango1.0-0:i386 (>= 1.12.3) but it is not going to be installed
                               Depends: libpopt0:i386 (>= 1.7) but it is not going to be installed
                               Depends: libtiff4:i386 but it is not going to be installed

Can someone help to solve this problem?

share|improve this question
add comment

1 Answer

Try with following commands ;

sudo apt-get remove libpopt0 libatk1.0-0 libcairo2 libgtk2.0-0 libpango1.0-0 libpopt0 libtiff4

sudo apt-get --install-suggests --install-recommends install cnijfilter-ip2700series
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.