Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've read about this, but still can't figure out my problem. I've got a new laptop with windows 8 preinstalled. First thing I did was installing ubuntu, then GRUB, as I always did. Now I can boot Ubuntu, but not windows. While the machine starts I get this message:

Failed to open \EFI\Microsoft\Boot\grubx64.efi - 80000000000000E
Failed to load grub
Failed to open \EFI\BOOT\grubx64.efi - 80000000000000E
Failed to load grub
Checking media [FAIL]
Checking media [FAIL]

Then GRUB shows up with 4 options

Ubuntu
Advanced Settings for Ubuntu
Windows Boot Manager (UEFI on /dev/sda1)
System setup

Selecting Ubuntu goes fine, but selecting windows outputs this message:

/EndEntire
file path: /ACPI(a0....)/PCI... etc.
error: cannot load image.

and it returns to GRUB menu. I've read, that installing GRUB with UEFI isn't a good idea. I always had BIOS. I can change the boot option to UEFI secure mode off and Legacy secure mode off. The second one says there are no boot images. How should I repair my bootloader so that I can choose between Ubuntu and Windows?

share|improve this question

3 Answers 3

up vote 2 down vote accepted

First, disable Secure Boot. It sounds like you may have tried this already, but that's not quite 100% clear from your question.

Second, as user207507 suggests, Boot Repair may be able to fix the problem. This isn't guaranteed, though, and in rare cases it can even render Ubuntu unbootable. (Making a backup of your EFI System Partition can provide you with a way back in case you have this problem.)

Third, you might try my rEFInd boot manager. You can try the USB flash drive or CD-R image (both available on the downloads page) without installing rEFInd to your hard disk. If you can boot both Ubuntu and Windows that way, try installing the Debian package in Ubuntu.

If these suggestions don't work, then please post back with the URL that Boot Repair generates. That will give us more detailed information about your system that will be helpful in diagnosing the problem.

share|improve this answer

The problem you are experiencing is related to SecureBoot rather than UEFI as such and seems to be a known critical bug: https://bugs.launchpad.net/ubuntu/+source/grub2/+bug/1091464.

You will find a number of workarounds under this link. The best one would be to use a SecureBoot-compatible loader such as shim or PREloader. Can't advise much further as I haven't personally had to handle this problem, I avoid anything Win8 as a plague.

share|improve this answer

Search for the Boot-Repair cd. And boot live. I've used this often when installing win7 after Ubuntu when dual booting. It brings back the correct options in Grub.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.