Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've noticed that sound becomes unavailable to me when someone else is logged into my machine and playing music (or has facebook open) in the other account. I've had to ask them to unlock their account and turn it off so I can get sound in my own stuff. Even in sound preferences, the hardware itself disappears and output is "dummy sound".

Is there a way to prevent this from happening?

What would be really good is if I could turn down the volume (or mute entirely) all the sounds on all other accounts on a per-user basis from my sound preferences without affecting whatever setting they have - essentially saying whenever user A is logged in, all sounds from user B's account are muted and anything from user C's account is at 50% while I can still have my own at full volume.

share|improve this question
add comment

2 Answers 2

Maybe a partial fix for your problem I found in an older Fedora thread about pulse audio: "Pulseaudio - Multiple Users"

Post nr. 5 says:

As the main user, I copied /etc/pulse/default.pa to ~/.pulse/default.pa. I added: load-module module-native-protocol-tcp auth-ip-acl=127.0.0.1 As the second user, I created ~/.pulse/client.conf and added default-server = 127.0.0.1

With this configuration, when the second user launches an application that uses pulseaudio, it will connect to the first user's pulseaudio instance.

However, AFAIK fedora uses different security subsystems and this might not work.

share|improve this answer
add comment

This is an old bug (launchpad 433654) related to per user sound configuration.

SOLUTION:

  • Check that there's no users at the 'audio' group
  • Uncheck the option "use audio devices" under "User administration" -> "Advanced" -> "Privileges"
  • Restart

Now you have a diferent sound instance per each user.

More info at the wiki of Ubuntu.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.