Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Im trying to run Juju on Windows 8.1 x64 and connect to my azure account. I'm having a terrible time finding info on how to actually configure the yaml file on Windows, there is no documentation out there....

In any case, my juju bootstrap errors out on the "management-certificate-path" setting. I have followed the standard documentation for generating/uploading a management certificate for Windows Azure, and pointing to this key in my yaml file (If I need to do it in some other way, then the documentation is going to have to tell me).

The error I'm getting is ERROR parsing environment "azure": no public ssh keys found

I've tried adding "" to the path, but that only results in "YAML error: found unexpected bladibla".

juju looks extremely interesting, but the lacking documentation throws me off. Could someone point me to a valid step by step for getting this to work on Windows?

share|improve this question

2 Answers 2

Try following this guide for setting up SSH keys on Windows: https://juju.ubuntu.com/docs/getting-started-keygen-win.html

And this guide for setting up Azure: https://juju.ubuntu.com/docs/config-azure.html

If there are things in there which are missing, unclear, or otherwise could be improved.... please tell us so we can improve it :)

share|improve this answer

The ssh keys are not put into the yaml file. You need to create a directory called .ssh in the directory of the user. You can not use windows explorer because it does not accept a directory that start with a dot. You should call it ssh and then use the move command in the msdos command line to change from ssh to .ssh. Afterwards you should use puttygen to generate a public and private key. Afterwards you need to rename the files to id_rsa and id_rsa.pub and put them in the .ssh. This issue is already escalated and hopefully a fix will come quickly.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.