Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I installed nodejs with the instructions from this post on ubuntu 13.1 All went smooth. After that I installed express by issuing the command

npm install express

which result in

express@3.4.4 node_modules/express
├── methods@0.1.0
├── range-parser@0.0.4
├── cookie-signature@1.0.1
├── fresh@0.2.0
├── debug@0.7.4
├── buffer-crc32@0.2.1
├── cookie@0.1.0
├── mkdirp@0.3.5
├── commander@1.3.2 (keypress@0.1.0)
├── send@0.1.4 (mime@1.2.11)
└── connect@2.11.0 (methods@0.0.1, uid2@0.0.3, pause@0.0.1, raw-body@0.0.3, qs@0.6.5, bytes@0.2.1, negotiator@0.3.0, multiparty@2.2.0)

but when I now type something like

express demo

I get

The program 'express' is currently not installed. You can install it by typing: sudo apt-get install node-express

share|improve this question

I answer my own question for the case that someone else stumble over the same problem.

The packages can be installed as local and global where local is default. We should install the package as local when we require it and as global when we want to access it within the shell. To install a package as global simply add -g in my case I run

sudo npm install -g express

and now it works.


Using -g and require it later can lead to UNMET DEPENDENCY express this can be solved by using -d

sudo npm install -d express
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.