Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just got this ZTE MF-195 USB wireless modem, and when I plug it in I get this message:

Unable to mount Internet Manager
Error mounting: mount: /dev/sr0 already mounted or /media/Internet Manager busy

The results of running lsusb are:

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub  
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub  
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub  
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub  
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub  
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub  
Bus 001 Device 003: ID 147e:2016 Upek Biometric Touchchip/Touchstrip Fingerprint Sensor  
Bus 001 Device 004: ID 04f2:b25f Chicony Electronics Co., Ltd   
Bus 001 Device 005: ID 0a5c:217f Broadcom Corp. Bluetooth Controller  
Bus 003 Device 005: ID 19d2:1514 ZTE WCDMA Technologies MSM   
X1:~$  dmesg | grep tty   
[    0.000000] console [tty0] enabled  
[    1.019341] 0000:00:16.3: ttyS4 at I/O 0x50b0 (irq = 19) is a 16550A

...so my device is Bus 003 Device 005: ID 19d2:1514 ZTE WCDMA Technologies MSM.

What should I do?

share|improve this question
    
You should be able to compile the latest sakis3g on Ubuntu now. Just follow the Debian/Ubuntu step in the README file. –  Trixarian Apr 12 at 13:15
add comment

2 Answers

I've had trouble with usb 3g internet sticks on linux before and got it working using sakis3g. Give it a try!

https://github.com/Trixarian/sakis3g-source

share|improve this answer
    
hi,i tried to do so but it seams i am missing some libraries ./compile Base directory: /home/r/Downloads/sakis3g-source-master. Source files: All found. Device database: Found and transformed. /tmp/ccOjkdz9.o: In function main': usb_modeswitch.c:(.text+0x191f): undefined reference to usb_init' usb_modeswitch.c:(.text+0x1934): undefined reference to usb_set_debug' usb_modeswitch.c:(.text+0x1939): undefined reference to usb_find_buss... –  baxy Nov 14 '13 at 12:12
    
i managed to instal it but i get message: Failed to connect –  baxy Nov 14 '13 at 12:55
    
also nm-tool does not show it... any suggestions –  baxy Nov 14 '13 at 16:49
    
ok i managed to mount my usb at least but what i get is just a a folder withall subsequent files in my /media/Internet Manager –  baxy Nov 14 '13 at 17:24
    
When I used sakis3g it was pretty straight forward, it recognized my usb stick, asked me some info, password and connected. There are some posts on the net about this modem if you want to take a look linux.org/threads/zte-lte-usb-modem-not-connecting.4491 but I also found a bug report and people say it could be a kernel issue bugs.launchpad.net/ubuntu/+source/linux/+bug/1173566 in that case you could try with the latest ubuntu version eventually. –  William Nov 14 '13 at 18:48
add comment

I would suggest using a precompiled copy of sakis3g. The current source code doesn't compile on all version of Ubuntu - especially since usb_modeswitch moved to using libusb1.

Try grabbing the copy I have @ http://trixarian.net/sakis3g.gz

share|improve this answer
    
Then how to compile it? –  Braiam Feb 23 at 14:58
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.