Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I searched here and google and all I could find is how in Ubuntu 13.04 forward mtp devices are supported. The answer I found are for ubuntu 12.04 or ubuntu 12.10

Well, I connected my phone in mtp mode and I don't see it on my machine. How can I see it?

Edit: Requested data

This is my phone (Xtreamer q)

I also tried a samsung galaxy s2 device, which popped an error message (unable to mount device). My phone didn't give such mistake.

And this is the output of lsusb and mtp-detect

└┌(%:~/Applications/Process.1dFit)┌- lsusb
Bus 002 Device 004: ID 04f2:b1fc Chicony Electronics Co., Ltd 
Bus 002 Device 005: ID 045e:009d Microsoft Corp. Wireless Optical Desktop 3.0
Bus 002 Device 007: ID 283b:10a3  
Bus 002 Device 003: ID 0424:2514 Standard Microsystems Corp. USB 2.0 Hub
Bus 002 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 004: ID 0a5c:217f Broadcom Corp. BCM2045B (BDC-2.1)
Bus 001 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
└┌(%:~/Applications/Process.1dFit)┌- mtp-detect 
Unable to open ~/.mtpz-data for reading, MTPZ disabled.libmtp version: 1.1.6

Listing raw device(s)
   No raw devices found.

I guess that the third text line from the bottom is the problem. But I don't what to do with it.

share|improve this question
Then that's not a problem with mtp support or Ubuntu but your device. Which you haven't told us. – LiveWireBT Nov 14 '13 at 8:22
Please edit your question and add the output of the following commands: lsusb and mtp-detect. Your android must to be connected when you run these commands. – Radu Rădeanu Nov 14 '13 at 8:42
I actually have the same problem on Kubuntu 13.10 with my HTC One X+. Ill be keeping an eye on this post for any answers and will post my own if I find anything. – Michael Aquilina Nov 14 '13 at 9:46
@Yotam It was your phone connected to your system when you ran lsusb and mtp-detect? If it was, as I can see, your phone is not detected. Try to connect it to another machine to see if the problem persists. – Radu Rădeanu Nov 14 '13 at 16:06
@Dadu Daideanu. On another machine I don't have that problem. I also tried two other USB ports with the same result. – Yotam Nov 17 '13 at 12:25
up vote 12 down vote accepted

I too had the problem that my "asus padfone infinity" was not mounted through mtp. (adb worked though).

Solution was to connect it through one of the USB3 Ports of my thinkpad instead of a usb2 port. Looks like the USB2 port is not recognized as usb2, or are devicenames for usb2 "usb1"?

syslog when connecting to USB2 Port:

Feb 21 13:59:55 t530 kernel: [39597.968522] usb-storage 1-1.2:1.2: USB Mass Storage device detected
Feb 21 13:59:55 t530 kernel: [39597.968634] scsi16 : usb-storage 1-1.2:1.2
Feb 21 13:59:55 t530 mtp-probe: checking bus 1, device 7: "/sys/devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.2"
Feb 21 13:59:55 t530 mtp-probe: bus: 1, device: 7 was not an MTP device
Feb 21 13:59:56 t530 kernel: [39598.966743] scsi 16:0:0:0: CD-ROM            ASUS     Device CD-ROM    0000 PQ: 0 ANSI: 2
Feb 21 13:59:56 t530 kernel: [39598.971140] sr1: scsi-1 drive
Feb 21 13:59:56 t530 kernel: [39598.971427] sr 16:0:0:0: Attached scsi CD-ROM sr1
Feb 21 13:59:56 t530 kernel: [39598.971580] sr 16:0:0:0: Attached scsi generic sg3 type 5
Feb 21 14:01:02 t530 kernel: [39665.530135] usb 1-1.2: USB disconnect, device number 7

Connecting to usb 3.0 port:

Feb 21 14:01:06 t530 kernel: [39669.292066] usb-storage 3-1:1.2: USB Mass Storage device detected
Feb 21 14:01:06 t530 kernel: [39669.292231] scsi17 : usb-storage 3-1:1.2
Feb 21 14:01:06 t530 mtp-probe: checking bus 3, device 2: "/sys/devices/pci0000:00/0000:00:14.0/usb3/3-1"
Feb 21 14:01:06 t530 mtp-probe: bus: 3, device: 2 was an MTP device
share|improve this answer
Apparently, this is the case with my machine as well. My (new) nexus 7 device is mounted through some usb ports, but not all. My phone isn't recognize at any though. – Yotam Feb 21 '14 at 16:56
This isn't the problem. I also get "device: 2 was an MTP device" but I'm still not able to mount my phone. – Cerin May 23 '14 at 15:53

I had the same issue, and the following worked

sudo apt-get install mtp-tools mtpfs
share|improve this answer
Worked for me on Kubuntu 13.10. Thanks! – Zaar Hai Dec 1 '13 at 12:47
Just worked for me too. My Nexus 4 was mouting, but won't let me open any folder, after those installs, everything is working. Thanks. – euDennis Jan 28 '14 at 13:15
Didn't work for me on Ubuntu 14.04 and with HTC Desire 500 on USB2 port. – Michaël Benjamin Saerens May 20 '14 at 7:35
Didn't work for me in Lubuntu 14.04 – August Karlstrom May 25 '14 at 12:37
I run the above + changed the settings on my device (in this case, a sansa clip plus by sandisk) to use MTP (System settings->USB->MTP) and it worked! – Elad Jul 21 '14 at 10:32
  • In Ubuntu (13.04,13.10) an android device which was connected in MTP mode was not detected if it was plugged in to any one of the USB 2.0 ports. For getting your device detected in Ubuntu, you have to plugin the phone in USB 3.0 port.

Port with black tongue - USB 2.0 port

Port with blue tongue - USB 3.0 port

Tested and worked in Ubuntu 13.04 and 13.10.

Note: you don't need to install any mtp tools.

share|improve this answer
Because a USB 3.0 host port will magically add support for an unknown/unsupported USB 2.0 only capable device to the library in question? I'm really curious for a good explanation. :) – LiveWireBT Feb 6 '14 at 15:02
Agree. What's the basis for this? It doesn't make sense. – Oli Feb 14 '14 at 13:04
@LiveWireBT, You won't get an explanation because this answer is complete nonsense. I have USB3 and it still won't mount MTP devices. – Cerin May 23 '14 at 15:54
You are making accusations instead of explanations. The protocol definitely works with USB 2.0 ports. Also, my mpt devices work fine on my T530, contrarily to the other answer. You shouldn't be bargaining with superstition (SE is not the right place for that). Instead of suggesting to always use USB 3.0 ports for 2.0 devices (this should only be a temporary workaround or may not work at all), you should help find the cause of this particular issue, include it in your answer and probably help to get it fixed. – LiveWireBT May 24 '14 at 4:34
That's not the point. The point is, that suggesting this as a permanent workaround is a very poor and esoteric solution to an obviously erratic behaviour that should be reported and fixed (and documented so everyone experiencing this issue knows how to act). Please stop bargaining for mediocrity. – LiveWireBT May 24 '14 at 5:14

Android fs can be explored if you MTP(media transfer protocol) file system on your system. Install the MTP file system on your system. Then try to plug your mobile. I tried on Ubuntu 14.04 LTS and android Samsung Galaxy S3. I hope, yours will be worked.

installation of MTP file system on ubuntu.

sudo apt-get install mtpfs

Now, unplug and plug your mobile. Then, restart your computer if still not working.

share|improve this answer

protected by Community Apr 3 '14 at 6:45

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.