Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just installed a clean version of 13.10 (Saucy) and tried to install Netflix using these instructions. The installation seemed to go fine, I opened Netflix after and it asked me to install a bunch of extra things through Wine, so I did. But after that, clicking on the Netflix launcher icon did nothing. No windows open, no error message...nothing. Then I tried running netflix-desktop from the terminal. It pauses for maybe ten seconds, then takes me back to the command prompt. No error messages or anything else is printed at the terminal. I tried running wine-browser too at the terminal and the same thing. However, if I run either of the aforementioned commands with sudo, it prints

wine: /home/jacob/.wine-browser is not owned by you
wine: /home/jacob/.wine-browser is not owned by you
wine: /home/jacob/.wine-browser is not owned by you

but otherwise the same behavior. Any idea what's going on? The only thought I have is that I installed an Nvidia close-source driver (version 319) and maybe that's doing something, but I have no idea. Any help would be appreciated.

share|improve this question

2 Answers 2

up vote 0 down vote accepted

Ok, so turns out that Pipelight is the best solution. I went ahead and followed their instructions for installing Wine, and it worked like a charm. It's great because I can run it in my browser of choice, unlike the original method of running netflix, which makes you use Firefox. If you're having the same problem, try this. http://www.webupd8.org/2013/08/pipelight-use-silverlight-in-your-linux.html

share|improve this answer

Simply run

sudo rm -Rf ~/.wine-browser  

NOTE that there is NO SPACE between ~/ and .wine-browser.

This will solve the problem and let you watch Netflix on Ubuntu.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.