Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I think its time to give up. I installed Ubuntu 12.04 two days ago. and wasted 36 hours on finding solution here at askubuntu and other forums, following them more than 4 times reinstalled Ubuntu but its such a waste , not because Ubuntu is not good, because there are so many different information here, so confusing for newbies like me. so thought it's time to get back to windows, still I want to try one more time, this time I again reinstalled a fresh Ubuntu and here is what I want.

I want to run blender 2.69.

what I have.
⠀i7 processor with 3gb
⠀nvidia Geforce 640 with 4gb ram

what I did so far.

tried many follow up here on askubuntu. got some response to my help call too. but they just keep quiet after a few answers and leave me in the middle of nowhere, then I have installed fresh and follow again different suggestion. the one I found very easy to follow is this tutorial but the installation of Nvidia worked and the installation of cuda failed, again I installed Ubuntu fresh one, and started second time this time the first step installation of Nvidia failed. now its fresh installation of Ubuntu.

Thanks for your response.

I have cuda 5, I dont know when I try to download there was more than one type Ubuntu 12.04 DEB** RUN DEB** RUN DEB

I just choose RUN.

I want blender to use my Nvidia graphics card for better performance, once I installed blender and it was working but in preference > system I did not find GPU or my Nvidia option, it was just CPU, so I removed it, for the link you provided I did not try that but I will try it and get back to you, if I can have your Skype would be nice, I will only bother you till my computer is up and running again properly with blender, :) thanks. the link provided to download blender at the page on your given link does not exist, but I will download it from the main side if it's OK.

I followed your step at the provided link, but...

...it's not clear how to open blender application, anyway I went to the folder containing blender and clicked on blender.exe and found this error message:

Archive:  /home/shams/blender/blender.exe
[/home/shams/blender/blender.exe]
  End-of-central-directory signature not found.  Either this file is not
  a zipfile, or it constitutes one disk of a multi-part archive.  In the
  latter case the central directory and zipfile comment will be found on
  the last disk(s) of this archive.
zipinfo:  cannot find zipfile directory in one of /home/shams/blender/blender.exe

...or /home/shams/blender/blender.exe.zip and cannot find /home/shams/blender/blender.exe.ZIP period.

and when I try to run from the terminal

shams@ubuntu:~$ sudo cp ~/blender /usr/lib/blender -r
[sudo] password for shams: 
shams@ubuntu:~$ blender
The program 'blender' is currently not installed.  You can install it by typing:
sudo apt-get install blender
shams@ubuntu:~$ 

...so, should I use sudo apt-get install blender?

These are links to my screenshots from Blender and Additional Drivers:
http://grab.by/s3K8
http://grab.by/s3K0
http://grab.by/s3K4
http://grab.by/s3ME
http://grab.by/s3N6

I have a new issue with my Nvidia GeeForce 640 on i7 processor can somebody help please. Thanks

here are some ouptu

shams@ubuntu:~$ /usr/lib/nux/unity_support_test -p Xlib: extension "GLX" missing on display ":0.0". Error: GLX is not available on the system shams@ubuntu:~$ lspci | grep VGA 01:00.0 VGA compatible controller: NVIDIA Corporation Device 0fc1 (rev a1) shams@ubuntu:~$

enter image description here

share|improve this question
1  
What have CUDA to do with Blender? Also, have you tried this askubuntu.com/q/110821/169736? –  Braiam Nov 14 '13 at 4:07
    
Hello Braiam, i dont know much about CUDA all i want is to get the most out of my nvidia gf 640, by reading some post here i have a feeling that CUDA is required in order to work Nvidia properly, because my Nvidia is also not working. and can you read my edited post, ? i follow your link and have some problem. –  shams Nov 14 '13 at 5:30

2 Answers 2

up vote 1 down vote accepted

Blender Install blender is available in the Ubuntu Software Center. It will solve your problem if you install Blender using the Ubuntu Software Center. Alternatively you can also install Blender from the terminal by running the command: sudo apt-get install blender.

In order to install the recommended proprietary driver for your NVIDIA GeForce GT 640 graphics card, search in the Dash for Additional Drivers. Click on the Additional Drivers icon to open Additional Drivers. From the list of Nvidia drivers, select the driver that has [Recommended] after it. That's the graphics card driver that will give you the best performance. Click the Activate button in the lower right corner to install the recommended Nvidia graphics card driver. Reboot to enable the Nvidia graphics card driver.

Here's how to enable CUDA with an NVIDIA graphics card. In Ubuntu 14.04 you need to install the nvidia-331 graphics driver or more recent in order to enable CUDA. You also need to install the NVIDIA CUDA runtime library. The Compute Unified Device Architecture (CUDA) enables NVIDIA graphics processing units (GPUs) to be used for massively parallel general purpose computation. Remove the existing proprietary NVIDIA driver and then open the terminal and type:

sudo apt-get install nvidia-331 libcudart5.5  

Then open Blender and select File -> User Preferences and it will open a Blender User Preferences window. As you can see in the screenshot CUDA is enabled in Blender in Ubuntu 14.04 with an NVIDIA graphics card that is similar to yours.

enter image description here

share|improve this answer
    
@Shams Cycles is a new render engine that is available next to Blender Internal. It is a raytracing based render engine with support for interactive rendering, a new shading node system, new texture workflow and GPU acceleration. It is still just a preview release. Link to Cycles Render Engine. Link to free Blender Manual pdf ebook. –  karel Nov 15 '13 at 2:14
    
I think posting link is also not allowed here. since you asked here is the screen shots. –  shams Nov 15 '13 at 10:12
    
2.62 should have that option if you have a graphic card and installed properly, my version is 2.69 i have been using this gpu option in my window, but i dont want to use window now. –  shams Nov 15 '13 at 14:48
    
and why ubuntu showing two different info, in saystem DATA there is no graphic card. and in additional driver there is one . –  shams Nov 15 '13 at 14:52
    
@Shams My graphics card driver is nvidia-current, the same as yours. My feeling is that this GPU option is just the tip of the iceberg. The Blender team wants to completely redo the Blender rendering engine to make better use of the GPU. Meanwhile we are getting less than optimal performance while we wait for the software to catch up with the GPU hardware. –  karel Nov 15 '13 at 14:57

Same for me, but here is what I usually do:

  1. Download Blender (2.69x64) from blender.org (in my case blender-2.69-linux-glibc211-x86_64).
  2. Create a directory in my Home called Programs.
  3. Untar the downloaded file there.
  4. Run Blender from the ~Home/Programs/blender-2.69-linux-glibc211-x86_64/, and the GPU option in user preferences is there.
  5. You can always create a menu entry for it if you want.
  6. I haven't tested it yet, but most likely overwriting the installed version files in /usr/bin/Blender-whatever-it-is should do it-do that at your own risk though. And I can't say if Yafaray and the ffmpeg libraries will work with this method.
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.